Sansa Clip 2GB Not Recognized


When I first got my clip everything seemed to function normally. However now whenever I try and connect the device to my laptop I get a message saying that the USB Device Not Recognized. On the device itself a message pops up says “Writing” and then “connected” with the arrows flowing between the computer and player icons. After a few seconds it switched to the fading Sandisk logo and then back to saying “connected” and then back the Sandisk logo etc. I have trawled through all the posts to see if I can find a solution but none of them work. Here’s some background:

My System:

OS - Windows XP SP2 with WMP 11 installed. 

USB 2.0 ports

The Clip:

Firmware version - V02.01.16F

Model - BE0812BHTK-2GB

Purchased about 4 months ago. 

Things I’ve tried:

  1. Plug in whilst on hold and centre button depressed

  2. Setting USB mode on clip to MSC only

  3. Connecting on multiple computers with multiple cables. 

  4. Holding on switch for 20 secs

  5. Formatting via on screen menu. 

  6. Installing MTP Tools

  7. Connecting on operating systems other than windows (linux variants)

  8. Charging unit from mains to have full power and then all of the above again. 

Obviously I can’t update the firmaware as I can’t connect to it!

Windows Device Manager shows it as unknown device - have also tried uninstalling rebooting and then reconnecting without success. 

Is there anything else I can try before I return it?


I am having the exact same problem… or i was but i tried a bunch of things and i cant remember what it is supposed to say when charging so idk if its working yet… i just got it from a friend and it worked the first time about 3 weeks ago… now its not. Can you tell me what the screen says when its charging?