My computer won't recognize my Sansa Clip +

When I plug it into my computer, it won’t charge and the computer doesn’t even read that it’s there. I have a black Sansa Clip + 4 GB and I’m using Windows 8.1. It worked fine until a few months ago, but I can no longer put music on it from my computer.

  1. Try a different USB port.

  2. Check in Device Manager to see if it shows up there.

  3. Try resetting the device by holding down the power button for 20-3- secs. (while uplugged from the computer). Release the power button, then press again to start it up.

1 Like

I tried the 3rd option and it worked. Thanks.


My first post here and I have the same problem. Among others…
I have two identical Sansa Clip 4GB. The first one (red) has served me well but the battery is not so good anymore, the clip on the back is broken and it looks a litte scrappy. But I’ts working fine. I have a (Sandisk) 16GB card in it. 

Recently I bought a slightly used black one. It came with a 2GB (Sandisk) memory card (not installed). 

First of all: when any of these card is used in the black player, it hang during startup when the logo is displayed the second time. Resetting will not make any change. 

Without extra memory card it starts up. So I plugged it in to my computer and transferred some songs. No problem. 

But: next time I tried it says “USB-device not recognized”. I get the Connected message on the device and the symbols as well. 

I have tried another computer, other USB-ports (no hub), other cables - nothing works. I have also tried to re-format the unit and reset to default settings. No change.

USB is set to MSC (have tested both and also Auto). 

FW is 1.02.17F - but can not be upgraded since I can’t acces the device.  

I have Windows 10. Device manager says: Unknown USB-device (request descriptor failed). 

I’m running out of options. What is you best shot? 

No one has any suggestions? 

From personal experience with my Clip Sports and from reading messages in this Forum, I have learned that the micro USB cable that comes with Sansa players will always exchange data with the USB port of a computer. Many other random micro USB cables will only be able to charge these players.  (I discovered that my Garmin micro USB cable wiill also work with my Clip Sport.)

   Here is a brief discussion about this topic I discovered using The Google.

Also with some (older?) computers, the rear USB ports may provide more reliable data communication than the front ports.

What happens when you use the micro USB cable that came with one of your Sansa Clips?

Not all micro USB cables are constructed to allow data communication, just charging.

See this link for a brief discussion:

What happens when you try using  a micro USB cable that comes with your Sansa Clip+  

Not all micro USB cables are capable of data communication with Sansa players.

See this link for a brief discussion.

Maybe try using the micro USB data cable that comes with each Sansa player. Many other random micro USB cables are capable of charging these players but they lack the extra internal wires for data communication.

Well, it’s the cable I’ve been using. The original cable. And since I have two Sansa Clip I’ve tested both. 

My hope is to send some kind of “reset” to the player. I think/hope that will do the trick. But how? 

Take a look at the solution submitted by Forum member “jonmyrlebailey” in March 2012.

Thanks for the tip but it didn’t work. I never got that far as in the link. 

My (black) Sansa Clip will never show up on Device Manager as a Mass storage device or a Portable device. My red does. 

Only as a Unknown device. 

“Windows has stopped this device becuase it has reported problems (Code 43)”

I’m stuck between a rock and a hard place…