Sansa not charging - Computer doesn't recognize Clip

When I plug my usb cable into the computer to charge my Sansa Clip, the Clip turns on and says its connected, but it isn’t charging.  Usually the computer recognizes the device is plugged in, but nothing comes up on my screen to access the files.  I always have to “safely remove hardware” to disconnect it, but since the computer doesn’t recognize it there is nothing to disconnect now.  When I unplug it, the Clip turns off because the battery is dead.  What to do?

maybe ur usb hubs are underpowered. or the clip is not recognised as self powered device… do u already have wmp11 ?? also try to connect in MTP mode …select from usb settings… i think ur connecting in MSC … and upgrade to latest firmware

I had the same problem.  here is how I fixed it.  plug the clip in and check your device manager.  see if you have a yellow exclamation mark next to the clip driver.  if you do just uninsall the driver and restart the computer.  then when you plug the clip back in it will reinstall and work again.  hope that helps. 

I’m having the same problem.  I tried connecting it to 2 different computers and I get the same problem.  My clip seems to be coming up as a “USB Mass Storage Device” in Device Manager.  It also has a yellow exclamation mark on it.

tipsypenguin, you mentioned something about uninstalling the driver.  What driver are you talking about?  It didn’t come with any drivers.

Anyone know how to fix this?

windows installs it’s own driver.  it’s just a generic mtp driver from microsoft.  if you have a yellow exclamation mark on it then the driver is not working.  just right click on it and uninstall it.  then restart.  when you plug the clip in again windows will reinstall the driver and it should work again. 

Thanks tipsypenguin, I plugged in the Clip and went to my device manager & clicked on view hardware and devices.  I found the Clip under portable devices, but did not see a yellow exclamation mark.  When I clicked on the Sansa it said it was disabled and so I enabled it and now everything is workling great.

I think the auto updates from 3rd party software screws things up in Vista.  I had some issues with my Adobe Acrobat Pro working with Vista after one of these auto updates.  Tech support at Adobe had me make some changes and disable some things to try and fix it.  Needless to say that solution never worked and so I had to uninstall and re-install Acrobat (twice now).  I disabled the auto-update feature now and all is working (knock on wood).

Same problem.  Upgraded to Windows Media Player 11.  Problem solved.

In my Device Manager, there was a yellow exclamation next to one of the USB Ports. I uninstalled that one, restarted my computer, plugged in the Clip and it started charging. The computer “Found New Hardware” and everything worked fine afterwards. Here is how you will go about this:

START > Control Panel (if it says “pick a category” at the top, click “Switch to Classic View” on the lefthand side)> System > Hardware > Device Manager > Yellow Exclamation (right-click) > Uninstall.

START > Restart > Plug in Clip > Newfound Happiness.

Best of Luck… The only weird thing mine does is randomly disconnect and reconnect itself real quickly so windows makes those “Found New Hardware” and “Hardware Disconnected” noises. -JC