cannot charge and not recognized

Big problem. I cannot charge my clip anymore. When I plug in the USB cable from the AC adapter to charge the clip, it shows as “connected” and animated pictures of Sansa and computer linking together instead of flashing battery icon to show the charging state. I tried to connect to the computer. It is even worse. My clip is not recognized by my computer as usual. It still showed up the same pictures of “connect” but there was nothing in device manager.

My firmware is 1.01.30A. I want to change to 1.01.32 to see if it can help, but my clip is not recognized now. I tried “hold down the center button” method, also changed the setting to MSC mode, but it still doesn’t work. What should I do?

First, reset the device by holding the power switch in the ON position for 20 seconds, then release.

Then plug in to the USB port.  The Clip should power up and the connected display should show.

With the device connected, open the device manager and locate the Clip.  Uninstall the device via a right click (or double click), and unplug.  If you’re impatient, try plugging in again after about ten seconds, and Windows will reinstall the device.  Better yet, unplug, reboot the PC, then after it’s stable, plug in the Clip again.

µsansa

I am having the same problem as pongup, I followed the steps you gave, but nothing… :frowning: I don’t understand what I’m doing wrong. I have followed the directions that are also posted on the sansa disk website as well like 6 other post on this website having to do with the sansa disk not being recognized by the computer and not charging but no luck.

    My clip was working fine then one day I connected it to wall charger and it displayed the clip n computer icon w/the arrow showing that  it was connected like when I use to connected to my computer… I disconnected cuz that had never happened before. I reconnected it and it still didn’t go away but it was low on battery so I still connected hoping it would charge it anyway so I left to run some errands. When I came back I checked it and it was less charged n the icons where still there. So hooked it up to my computer only to find out that it wasn’t being recognized by my computer at all. I tried to reset it and did the whole 20 sec hold and nothing. I even format it and reset it and nothing. plz if there is something else u anyone can offer I would greatly appreciate it. Thank you :smiley:

If the device status changed, using the same AC adaptor, it’s possible that there is a fault in the adaptor- applying power to the data pins.  If so, the “connected” icon will display, as the Clip sees something on the data line.  This connection may, perhaps,  be happening within the USB / Mini-B jumper cable;  if you have another cable, this is worth a try.

If the Clip thinks it’s connected, but cannot communicate on the data bus, it can get stuck in a loop where it will default to “charge off” while waiting for data.

Bob  :wink: