Sansa Clip is charging but not detected


I have a sansa clip that my friend gave to me last week. Everything works on the unit. But there is one issue i havent solved until now. When i connect the unit to a PC using a USB cable, it automatically directs to the Menu without the “connecting” word appearing. The battery icon blinks which indicates that the unit is charging. But the player cant be detected by the PC, nothing really happens. My sansa clip charges but doesnt connect. I tried every possible solution that i have found on other sites. I have tried connecting it to other PCs and using different cables. I just cant make it connect.

Please help!..


Assuming that you have tried other USB ports and you have tried MSC mode (settings > USB mode), it could be a problem with the cable that you are using. USB cables have four pins, it seems that the data pins are not working. i would suggest you try a different cable.

Have you tried switching it to MSC mode? (Settings > USB mode > MSC)

I have the same problem, and have tried both MTP and MSC modes. I have tried installing new drivers, and working with the device manager. all to no avail.

I guess it’s time for both of you to contact SanDisk tech guyz

SanDisk Contact us