Sansa clip 2GB not detected by PC

Hi, i have a sansa clip 2gb that was working fine until yesterday, pc(vista) not detecting device, keep getting error message “USB device not recognized” unable to update firmware (currently 01.01.11A) due to device not being detected by PC. No option to change the USB mode on settings Tried the hold switch and hit rewind button while connecting to pc to change the usb mode and that did not working either, i have media player 11. Now i have no battery on the clip since pc not detecting not charging it either. Tried connecting it to different pc and not being detected, tried 3 different usb cables and no luck, gettin ready to throw this thing out the door, please help!!!

I’m not sure but this message thread might help,   Cheers

Be sure to try both MTP and MSC USB modes with your computer.    Read in the FAQ more about this .

If there is power at your usb port,  even if its not connection datawise,  you should be able to turn on the clip and it should start charging.   If it worked before.    You can also try a suitable AC adapter to charge it.    I did find that if the unit isn’t alive / on,  it won’t charge.

be sure to follow the links on and contact thier technical support too.

Good luck,  Cheers