Sansa clip not able to detect on any PC

Hi

Everyone,

I am big time frustrated due to my Sansa clip 2 GB MP3 player, I am not able to do anything apart from Charging my device and listen proceeded default music files, radio. But not able to add/del any files. In short my Clip is not getting detected on any Machine ( OS i have tried Xp, Xp2, Vista, Win7). I have also tried changing USB cable but it just charges and doesn’t get detected at all ( No new device found ) , tried putting it to MSC/ MTP but no change.

The firmware version it has is : V01.01.18A  

Lastly, as tech support asked me to update my firmware, the Question is how I can update my old firmware if the device is not getting detected at first instance. I have tried all tips/tricks mentioned on sansa website but it doesn’t work for me.

I have OS XP2, P4 dual core, 4 GB ram, Windows Media player Ver 10.0 hence don’t think machine has some issues, also tried on 2-3 different configuration machines. I have lost my driver cd which came along with this device, i am not sure whether i am gona need that to trouble shoot this problem.

Please need help from some geek :frowning:

You might be out of luck. That is why I wish Sandisk would allow firmware updates for all its players with a card slot either through the usb connection, or via having the firmware on a card inserted in the player.

I don’t know if this is possible to implement on current models, but I hope they have this on all future models.

The Clip doesn’t have a card slot anyway, but all of Sandisks newer players have a card slot.

…Hello, I have same problem. My 4GB sansa clip v01.01.18A  don’t detect to any PC. It only acts like charging. :frowning: please help

@aljonlopez wrote:

…Hello, I have same problem. My 4GB sansa clip v01.01.18A  don’t detect to any PC. It only acts like charging. :frowning: please help

Try changing the USB mode to MSC or changing the cord.

I also have the same problem with my 8G Sansa clip. None of my computers will pick it up. I’ve tried both MTP and MSC mode with two different cords. I’ve tried finding it with Add Hardware Wizard. It’s like it’s not even plugged in.  Nothing will detect it, all it does is charge. On the other hand it will pick up my dad’s Sandisk e280.

This also happened right after I uninstalled Norton from my computer.

M SANDISK NOT RECOGNIZE MY PC WANTS AND OCCUPY SANDISC PROGRAM

SORRY–NO FOLLOW. :wink: