Sansa Clip 2gb Cannot be recognized anymore

The title says my problem.

As other threads messages suggests, 

I dont have the USB option on my Sansa clip, So what I did is sliding it on Hold and pressing the center button as I connect it to all the USB ports of my computer and even tried using different USB cables, but still. No chance

Ill I get was my Sansa clip being charged

HELP!

Thanks!

Have you tried running the Sansa Firmware Updater (http://www.sandisk.com/Retail/Default.aspx?CatID=1376) even though your PC doesn’t appear to recognize your Clip?

And so power connects but not data?  Did you try other USB cables, and other computer USB ports?

You also could try to reset (on switch held up for 15-20 seconds) or a Clip reformat (under Settings–but this will erase your files).

I did tried that updater with my internet connection on, but still cant detect the device.

I tried checking in device manager, but still nothing, not even an unknown device.

And I also tried different cables and usb slots.

And also tried puting it on (lock)hold and pressing center button upon connecting thru USB, still nothing.

Its only charging

BTW:

How would I know that is it on MTS mode? (hold+center button)

When Im doing that, what happens to the clip screen was the normal startup and the locked icon. No sansa drive is appearing on my computer even for holding it for about 10 secs and more.

Its just charging batteries

Message Edited by soyuz1234 on 06-25-2009 03:57 PM

Go back to www.sansa.com.  But, instead of going into the forum, go into KNOWLEDGEBASE (to the left of FORUM) - look at the first # 1.  It will be under solution 2 - something about refreshing your drivers.  I did this and it fixed my Sansa clip.

Julie

@soyuz1234 wrote:

 

How would I know that is it on MTS mode? (hold+center button)

 

You mean MSC mode.

 

It doesn’t look any different than if you are connected in MTP mode.  The display will show text “Connected” (sometimes switching back and forth between that and “Writing” ), and a graphic of a Clip and a computer with two animated arrows between them.  This will cycle back and forth with a display of the word “SanDisk”.

 

The only difference between the two modes is that when you’re in MSC mode, your Clip would show up as a “Removable Disk” with a drive letter under “My Computer” (Windows Explorer).  In MTP mode, it shows up as a “Portable Media Player”.

 

But I’ve found that even if you have the Clip in MTP mode, the Firmware Updater will recognize it and check its firmware version.  Most likely it puts the Clip into MSC mode temporarily while doing the firmware check/update, though I’m not sure about that.

I just cant run it into MSC mode.

When Im doing that, nothing happens but the batteries getting charged. No detection from my computer at all

Try a different computer, and let us know what happened.

I tried it on my laptop and desktop. Both windows.

One thing bugs me though is I dropped this from my bed. About 2-3 feet. But I am also tend to drop accidentally my other gagdets from my bed but they are still working fine.

What a nightmare.  I have a 4gb unit that does the same thing.  Sometimes it mounts but the majority of time it does not.  I confirmed it had the latest firmware but last time I was able to get it to mount I reloaded it anyway.  I have tried what I believe to be every “fix” listed within the forum with no success.  I guess all I have to say is that I am glad this unit is my secondary because I can’t spend days trying to get it to mount when I want to load an album.  Silly how it says goes between connected and writing when it actually is not and although it says it is charging the battery I am suspicious of that as well since it’s not mounted.  Here is what I have tried:

  1. MSC & MTP Modes

  2. Resetting

  3. Reformatting

  4. http://kb.sandisk.com/cgi-bin/sandisk_en.cfg/php/enduser/std_adp.php?p_faqid=42&p_created=1221328944&p_sid=2AplevBj&p_brand=sansa&p_accessibility=0&p_redirect=&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9ODgsODgmcF9wcm9kcz00LDE0JnBfY2F0cz0wJnBfcHY9Mi4xNCZwX2N2PSZwX3BhZ2U9MSZwX3NlYXJjaF90ZXh0PXNhbnNhIGNsaXAq&p_li=&p_topview=1

Every supposed solution step in this Knowledgebase including downloading and installing the MTP Porting Kit

  1. Plugging it in with hold switch and middle button pressed.

  2. Tried on main system Vista, alternate system XP

Don’t know what’s left.  I’m running Vista SP1 as admin and am now extremely frustrated, especially since sometimes it works and sometimes it doesn’t on both Vista and XP systems.  If it would work 90% of the time I would only be upset but it seems to work about 5% of the time.

UGH!!!  Time for something new SanDisk.  I want to love this product but your technology is not convenient!

I have the same problem. My sansa clip has always worked, all of a sudden the computer doesnt recognize it anymore, and it only charges batteries.

I did all of the instructions from

http://kb.sandisk.com/cgi-bin/sandisk_en.cfg/php/enduser/std_adp.php?p_faqid=42&p_created=1221328944&p_sid=2AplevBj&p_brand=sansa&p_accessibility=0&p_redirect=&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9ODgsODgmcF9wcm9kcz00LDE0JnBfY2F0cz0wJnBfcHY9Mi4xNCZwX2N2PSZwX3BhZ2U9MSZwX3NlYXJjaF90ZXh0PXNhbnNhIGNsaXAq&p_li=&p_topview=1

and it still doesnt work… 

Ill try some more things and report back if I manage to solve the problem.