sansa clip and pc dont recognise eachother

I was wondering if the usb cable is damaged as it has a kink in it. Nothing at all happens when i plug in, except the battery charges.

oh, my OS is vista

Is the Clip in MTP mode?  Settings/USB Mode/Auto Detect or MTP…

Put in MTP mode and plug back in.

If it still does not show up, then check the device manager and let us know if any messages show up (yellow symbol).

yes tried that, to put it in mpt mode all i have to do is press centre nav key right? What does it mean by press and hold? I tried all combinations, and nothing shows in the device manager.

You should not have to push any buttons.  Once you plug it in, is there a message that pops up?

no message at all, on either

maybe you should update to the latest firmware ???

you can download the Sansa Updater at their site http://www.sandisk.com/sansa

i tried everything they suggested on that site earlier today…i really want it to work, the radio works and sounds fab, and there isn’t another product that i like as well as this, please help!!!

Did you try another USB port?  Try one on the back of the computer near the power supply.  You may want to try another cable just to rule that out.  Also, try another computer to rule out the Clip.  If it works on another computer, then we can narrow the problem to your computer.

i tried all usb on my laptop, which is only 2 months old…im going upstairs to try the desktop

ok, doesnt work on any port on the desktop, but, the sandisk did say it was connected on my partner’s laptop, which is an older version, though it said it failed to initialize, why wont it work on mine…seems finicky

omg it happened to me too…its not recognizing it…but its sorta charging…but it takes foreve to charge…ughhhhhhhhhhhhhhhhhhh…i

Is this what’s supposed to happen? (I didn’t load the software that came with it.)

I plugged in my brand new Clip (“vintage” computer, but XP is mostly up-to-date).  I didn’t see a new drive in Windows Explorer.  I was going to change the USB mode and see if that worked, but FIRST I went to Windows Media Player (10) and hit the Sync tab.  It correctly showed me a 2G Clip, and I could view the contents from there & Sync it. (So, even though Explorer didn’t find it, Media Player did.)

No problems, I got my son’s music on it, but I’d rather treat the Clip as a flash drive in Windows Explorer, and do straight copies.  Is that what changing the USB mode might have gotten me? 

(I apologize for asking instead of just trying, but it was late, and it’s a birthday gift for my son which I needed today. And I’m probably not going to get the Clip back again until it needs to be charged!)

Thanks.

If you switch the Clip’s USB mode (under Settings) to MSC, the Clip is treated/seen as an external drive; no WMP needed.  Nice and clean and good for everything except DRM’ed files.

Thanks, I’ll try the MSC setting next time. 

It’s a cool little gadget!