Need help installing Sansa Clip

I just received my brand-new Clip 4.0 gb today with hopes of loading lots of audiobooks tonight.


Bottom line:  My home PC (Windows XP, WMP 11.0.5721.5230) won’t recogniz the Clip but my work PC found it immediately upon connection.


At home when I plug the device into (multiple) USB ports on my PC, I repeatedly receive the “USB Device Not Recognized” message.  I found the suggestions on the Sansa Support page and updated to the latest version of Windows Media Player – no luck.


I was able to charge the device enough to change manually to MSC mode – still no luck.


I tried running the Sansa Firmware Updater (current firmware = V01.01.18A) with no luck.  The Updater doesn’t load and I’m guessing it doesn’t “see” the Clip.


When I connect the device, the PC says device unrecognized and the Clip says “connected” with arrows flowing between the picture of the Clip and the PC monitor.  The battery isn’t charging, however.


Is there something magical I can try to get THIS PC to recognize the device?


I appreciate any suggestions you all may have!






This is exactly the problem that I am having and it is SO frustrating. We shouldn’t be having these problems.

Seems to be an ungoing problem. I can’t install this clip on any of the 3 computers I have including a brand new Vista. Tried every possible suggestion and nothing works.

You could try reinstalling your PC’s USB driver. Right-click My Computer and select Properties. Click on the Hardware tab, then Device Manager. Scroll down the list until you see a device with a yellow icon with an exclamation point next to it. Right-click the device and choose Uninstall. Then reboot your computer, wait a few minutes for Windows to finish starting up, then reconnect your Clip. Your computer will automatically reinstall the driver, and if all goes well, your Clip should be recognized.

I have a similar problem.  My clip works perfectly on my laptop XP sp3 and WMP11, but when I try to use my other computer the hardware wizard starts up.  I follow the wizard’s instructions, but at the end an error message shows ‘Cannot Install Hardware’   ‘An Error Ocurred during the insatallation’  ‘The data is invalid’.  This system is also XP, and the wizard cannot install the clip and it does not show up on ‘my computer’.  The clip has the latest firmware, and when I look in device manager it shows the clip with a yellow ? and a message to install driver and 'this device is not configured correctly (Code 1).

I have tried changing settings to automatic, MTP and MSC. The hardware wizard finds he clip as MTP and USB storage device but cannot install it.

I have spoken to Sandisk support who said to install the new firmware (already done that) and reload Microsoft USB drivers - not sure how to do that.

Even reinstall XP Service Pack 3 in desperation.

Help if possible please

Message Edited by paynes1 on 02-05-2009 01:15 PM

There are two modes of operation open to you with the Sansa, MSC, where the Clip is a flash drive, or MTP, where it’s seen as a media device.

If you connect the Clip in MSC mode, open the Device Manager via [Windows key] + [pause / break], or Control Panel, click on the Hardware tab, then select Device Manager.

Look at the Universal Serial Bus Controllers listing at the end, and expand it.  Usually, the wee Clip will be hiding on one of the USB Root hub points.  Windows often likes to hide its problems under the rug: click on the Power tab for each one, and as it’s a USB2 device, you will find the location using the power tab.

Once you’ve found it, double click or right-click, and select uninstall.  You may also select uninstall from the Drivers tab.  Curious, how Microsoft has so many possible ways of doing the same thing.

Unplug, reboot the PC, and the device driver will be corrected for MSC mode.

Now, as for MTP mode, this is a virtual mode, driven by Windows Media Player (whether or not you use WiMP to manage the device).  You need WiMP11 (10 will also work, but I’ve found 11 better) for MTP mode.  If you manually select MTP on the Sansa, plug in, and look for it under Portable Devices this time, in Device Manager.  You can uninstall the device, and reboot again, to reinstall this driver.

If unsuccessful, reinstall WiMP11.  Please note that reinstalling WiMP will leave your music library intact.

Bob  :smileyvery-happy:

Thanks bob I’ve tried everything you have suggested (except reinstalling WMP11).  The computer realizes I’ve attached the player whether I’ve set the settings as MTP or MSC and tries to install it using the hardware wizard, but the installation fails.

The player is shown in hardware manager under other devices with a yellow ? without any drivers.(it is in drives on my laptop with a Microsoft driver)  When I select reinstall drivers it goes through the same process and fails-it is almost as if the windows generic USB driver is missing which is why I reinstalled SP3.   

WMP11 does not recognizes it at all.

The Sandisk support seemed to think it is a problem with XP and drivers.  To test this I have just tried plugging in a USB hub that I would expect to be recognized but the same has happened.

Any more thoughts appreciated.

Steve P



My Sandisk M240 works perfectly?

Ah, how about we try refreshing the USB root hub?  Unplug everything except for the mouse and keyboard.  Once the computer installs the correct tidbits into the registry, you’ll see the Sansa just fine.  Then, plug in your accessories (printer, etc, ) again.

As a footnote, do you have the PS3 drivers installed on your machine?  I’ve heard of conflicts with the Sansa versus the Sony.

Reinstalling WiMP11 can cure a whole range of issues.

Also, from a command prompt (Run Box) > enter cmd > {Then, in the command line, enter:} Net localgroup Administrators localservice /add

Bob  :smileyvery-happy:

Thanks again Bob,

Tried all of that but no joy - no PS3 either.  The hardware wizard finds the clip as either MTP or MSC but does not seem to be able to ‘add’ a driver.


Steve P