MSC vs MTP

I’ve had a Sansa C200 for a long time and have always used in in MSC mode (though I didn’t realize that until recently), where the player shows up as a separate drive letter in Windows XP.  Recently I got the Sansa Clip for my wife and couldn’t get XP to recognize it; at least not until I used the trick of the hold button and pushing the center button while plugging it in.  But I couldn’t leave well enough alone and tried to get it to operate in MTP mode.  Well, I succeeded but now the computer won’t recognize my other player, whether it is set to ‘auto-detect’ or "msc’ mode (its two options).

To get the clip to work in MTP mode, I did several things, including installing Microsoft’s MTP Porting Kit and their MTP Enhanced Specification. I also installed WMP 10 and then the next I installed WMP 11 (I had been using version 9, though I use Real player most of the time).  Anyway, I’ve then tried retracing my steps by uninstalling each of those things (using Add/Remove programs) but nothing seems to help.  I even tried using System Restore but every restore point I tried eventually came up and said that the restore cannot be done (glad I wasn’t depending on that for something really serious).

I also did a bunch of XP security fixes (I don’t let Automatic Update work on its own) and I haven’t un-installed all of those yet but maybe I will.  The fact that XP still recognizes my clip in MTP mode tells me that I haven’t quite gotten back to my original condition but I don’t know what else to try. 

I’d appreciate any ideas.  I’m getting tired of messing with this!  Thanks in advance.

Geo

If I’m understanding it right, “auto-detect” is just “MTP if the computer can do it, MSC if it can’t”…so the computer should be able to see your c200 no matter what. Does it show up in Device Manager? Maybe the computer’s done something stupid like “the device has been prepared for safe removal” where it’s just windows being a dork and not anything actually ~wrong~.

I think you understand it right, it’s just not working that way.  The pc is not recognizing the C200; it shows up in the device manager list as “unknown device.”  Somehow I’ve managed to update the XP USB drivers to see the MTP mode on the Sansa Clip, but it refuses to see it on the C200, whether I use “auto-detect” or not.  Equally odd, the pc DOES still recognize my flash drive, which I understand had the same type of file system as the mp3 player using MSC mode.

From what I’ve read, auto-detect actually has something to do with compatability with the Xbox, believe it or not.   I could Google it but I’m too lazy right now.

Autodetect with the Clip is supposed to determine if your computer has what is needed for a connection in MTP mode; if you do not, then connection via MSC mode.  I am not aware of an Xbox connection …

Actually, Autodetect does not work with XBox.  If you want MTP you need to select MTP for the XBox to recognize it properly as a MTP capable device. Otherwise it will set MSC mode,  (which is fine for many users).

Also,  The XBOX can play  DRM protected content (like Rhapsody Content) out of the Clip (streaming it over USB) in this mode.

Miikerman wrote:

Autodetect with the Clip is supposed to determine if your computer has what is needed for a connection in MTP mode; if you do not, then connection via MSC mode.  I am not aware of an Xbox connection …

Hmm, what happens if you set it to MTP mode and then connect to a system that doesn’t support MTP, such as a Linux system?

I’ve tried the streaming USB function with my Clip…is cool, no?

Bob  :smiley:

On one of my computers, I have to set the Clip to MTP to get it to detect properly.  I cannot set it on “Auto-Detect”.  It keeps trying to re-install the drivers and ultimately fail.  I can set it to MSC and get it to work.  The “Auto-Detect” is the culprit.

My other computer – a newer one – will recognize the Clip in “Auto-Detect” mode.  It detects as MTP.

Both computers have XP Pro SP3 with all the updates.

I’ve had a Sansa C200 for a long time and have always used in in MSC mode (though I didn’t realize that until recently), where the player shows up as a separate drive letter in Windows XP.  Recently I got the Sansa Clip for my wife and couldn’t get XP to recognize it; at least not until I used the trick of the hold button and pushing the center button while plugging it in.  But I couldn’t leave well enough alone and tried to get it to operate in MTP mode.  Well, I succeeded but now the computer won’t recognize my other player, whether it is set to ‘auto-detect’ or "msc’ mode (its two options).

To get the clip to work in MTP mode, I did several things, including installing Microsoft’s MTP Porting Kit and their MTP Enhanced Specification. I also installed WMP 10 and then the next I installed WMP 11 (I had been using version 9, though I use Real player most of the time).  Anyway, I’ve then tried retracing my steps by uninstalling each of those things (using Add/Remove programs) but nothing seems to help.  I even tried using System Restore but every restore point I tried eventually came up and said that the restore cannot be done (glad I wasn’t depending on that for something really serious).

I also did a bunch of XP security fixes (I don’t let Automatic Update work on its own) and I haven’t un-installed all of those yet but maybe I will.  The fact that XP still recognizes my clip in MTP mode tells me that I haven’t quite gotten back to my original condition but I don’t know what else to try. 

I’d appreciate any ideas.  I’m getting tired of messing with this!  Thanks in advance.

===========================

try another computer for you c200 just to isolate if the player itself is causing the issue. if it works w/another computer(should be xp w/wmp10+) then there’s nothing wrong w/the player. if no, then you might need to isolate between the c200 and its cable. sometimes if there’s no proper connection set to the computer, the player will not be recognized properly even if its inside device manager.

I have same problem as Decker. My clip (red 2 GB purchased from BB 2/14/08 running version 20), for no apparent reason, stopped being recognized in MTP on my computer. It is recognized in MSC on my computer. I tried CliPm0j0’s suggestion and my husband’s computer does recognize my clip in MTP. (That allowed me to delete BRhapsody. Whew!) Both computers are running Microswift XP. I will use MSC on my computer for now. What should I do if I ever want to get recognition in MTP again? Should I try Decker’s fixes, even though they didn’t work for him?

Arcane question for the musically inclined: In the past, when I my player was recognized, the connection “ding” was a rapid perfect fifth from C to G. The disconnection “ding” was a G to C. Now when I try to connect in MTP I get 3 rapid C tones and no recognition. When I disconnect, I still get the G to C. Anyone know why? (MSC has the correct dings, plus the cork-popping sound to remind you you’re in MSC and need to click the icon to safely remove.)

Sorry, my problem is not the same as Decker’s. My computer won’t recognize it in MTP. I will go back and look for some fixes for that. Will post again if I can’t find the fix. Sorry to waste the space.

OK. I found the fix in the forums. Uninstalling and reinstalling WMP 10----> 11 worked. Thanks for your patience with me while I learn to navigate the search feature.

–rioX, talkin’ to myself again.