Auto Detect not working; can I switch to MSC?

After trying all the fixes, I’ve concluded that my auto detect mode is simply not working and the drivers or whatever can’t be fixed. my computer (XP S3) simply doesn’t see the sansa clip+.  

But in MSC mode, it does see it.  Unfortunately all the audio books that are loaded now are not seen when exploring in MSC mode; it brings up the Sansa clip folder but shows all folders as empty even though there are 4 books on there.

My questions: 1) is there any disadvantage of using MSC mode?

  1. is there any way to get MSC mode to recognize the books on there now, or do I need to reformat and start over?

Oh and the other mode is not recognized either.  

thanks, I would hate to just throw this thing away.!

phil the perplexed 

If I understand correctly, MTP mode is broken on your PC, and the the device is reverting to MSC mode.

No worries, you can use MSC, but you lose the background functions of MTP.  Depending upon your audiobook source,MTP is required for the DRM (license) capability.

I believe Audible can be used in MSC, as their DRM is a little different.

To fix the MTP system (if the device communicates in MSC, you’re almost there, as data is making it to the device), manually select MTP mode to keep the Auto Detect from reverting to the other mode, and plug in.

If you open the Device Manager, find the Clip listed under Portable Device.  The Device Manager can be found by starting at the Control Panel.  Double click on the Sansa, or right click, and select Properties > Driver > uninstall.  I like the shortcut right click directly to uninstall.  easy huh?  Then, unplug the device, wait a moment (30 seconds should suffice), then plug in again, and it will reinstall automatically).

Remember, the MTP drivers are part of Windows Media Player 10 and later.  Windows XP came “out of the box” with WiMP 9, so that can be upgraded by simply installing WiMP10.  The Microsoft MTP Porting Kit application is available at the Microsoft website too, quite often installing the Kit repairs a frazzled WiMP 9 and later installation.

Why does MTP disappear?  Quite often, the registry entry for the Sansa is the key, as MTP capability is simply “turned off”. The registry is fragile, often modified as you plug in various things on those USB ports, or install different applications.  Windows uses the registry as a handy cheat sheer to decide how to handle devices found on the USB bus.  If the entry is corrupted, we suddenly lose functions like MTP.  Try the reinstall trick, it is the most basic fix, and usually solves the issue.

Bob  :smileyvery-happy:

Thank you Bob, both for your excellent solution and for the background explanation. the registry files were installed again and I can see my books! 

I had tried the ‘uninstall’ thing about 4 times before, following Sansa solutions to the problem, but none had mentiond putting my clip into MTP mode before inserting the USB or, taking it out and waiting 30 seconds.   Perhaps I misread them but I don’t think so. 

I presume that MTP mode is really the same as autodetect mode and I will leave my clip set to MTP.

Thank you again for your cogent, easy to follow and (most importantly) WORKING solution!


All that Autodetect mode does is select between MTP and MSC modes, depending on a computer’s capabilities.  Some of us don’t like the player switching between modes between sessions, and so choose one or the other.

Exactly, Auto Detect is handy in a few unique situations, it’s primary purpose is to facilitate getting that first connection.  If the computer has MTP capabilities, the Sansa will connect accordingly.

The downside of this arrangement is that the connection protocol can revert to MSC if there’s a problem.  While trying to diagnose it, guess what happens?  You’re looking at a basic MSC connection session.  This is why it is best to manually select the connection mode once you’re set up.

Glad to hear that you’re up and running.  I prefer MTP for my devices, with faster database refresh and the little automations that happen in the background when the Sansa is addressed as a media device.  For transferring data, diagnostic tests, and more, I manually switch to MSC for that.

Bob  :smileyvery-happy: