Completely Frustrated... any help before I return the clip again?

Love the idea of the Sansa Clip, hate that I’m having so much trouble getting Windows Media Player to recognize the device.

I have Microsoft Windows Vista, Windows Media Player 11, etc. and cannot get the Windows Media Player to identify the Clip as a device withinWindows Media Player.

Any hints or suggestions would be welome;  I hd bought the 2GB Clip and returned that because there was no documentation re: “Plays for sure” on the 2GB, so I returned the 2GB and got a 4GB, but I’m having he same problem.

Help please… :manmad:

Need a litte more info:

  • Are you using MSC or MTP mode (try both to see if either one works)?
  • Have you tried different USB ports (back of computer versus front)?
  • Are you using a notbook computer (many have low power issues on the USB ports)?
  • Have you tried another computer?
  • Have you tried another cable (most digital cameras use the same cable)?

 99% of the time connectivity issues are due to problems with the computer/OS and not the Clip itself.

As for the documentation for the Clip…it can be found HERE.

Select Clip from the Model drop down menu.

Thanks.  I like the BSG reference.

Just tried both MSC and MTP modes, my hp labels it as the “F:” drive, but in Windows Media Player, neither recognizes it as a device to sync with though the media player itself does display that it detected the device.

Another computer/another cable will have to wait until I get access to another one, but truth be told, y the time I get near some, the troubleshooting and issue with this product will have been too great and I will have returned it.

Any other hints?

If you’re getting an F: drive, that means that at least MSC mode is working and there’s probably not a hardware issue with your computer or cable.

While you’re still in MSC mode, try installing the latest FW (there’s a sticky at the top of this forum with instructions and download).  Even if you already have the latest, go ahead and reinstall.  Don’t use the Sansa Updater tool, just download the FW and unzip the the files to the Clip (the root of the F: drive).

After the FW upgrade, try switching back to MTP mode and see if WMP will recognize the Clip (I think MTP mode is required for WMP Sync).  Also, don’t use Auto mode, explicitly select MTP mode.

Note that you won’t get an F: drive in MTP mode.  The Clip will show up in Windows Explorer, but it won’t have a drive letter.  If the Clip doesn’t show up at all then the problem is likely with WMP.  Maybe try to uninstall/reinstall WMP11.