getting computer to recognize sansa clip problem

I can’t get my computer to see the Sansa clip in Windows explorer.  I guess the first time I plugged it into the usb port I overlooked the message about loading files from explorer.  Can anyone please suggest a way to get the computer to recognize the sansclip so I can drag and drop files from explorer rather than using media player or musicmatch?

Thanks very much in advance for your help,

gary

Wreagle88 wrote:

I can’t get my computer to see the Sansa clip in Windows explorer.  I guess the first time I plugged it into the usb port I overlooked the message about loading files from explorer.  Can anyone please suggest a way to get the computer to recognize the sansclip so I can drag and drop files from explorer rather than using media player or musicmatch?

 

Thanks very much in advance for your help,

 

gary

Do you have your Clip connected to your PC in MTP mode, or MSC mode?

 

To connect it in MTP mode, you just plug it in to the USB port without doing anything else.  It will then show up in My Computer as name “Sansa Clip 2GB” (or 1GB), type “Portable Media Player”.  You drag and drop your songs into the “My Computer\Sansa Clip 2GB\Internal Memory\Music” folder.

 

To connect it in MSC mode, you slide the hold/power switch to hold, then press the center button while plugging it in to the USB port.  It should then show up in my computer as type “Removable Device”, with a drive letter assigned.  You then drag and drop your songs into the X:\Music folder, where “X” is the drive letter assigned to your Clip. 

 

If you don’t see your Clip in My Computer, regardless of MTP/MSC mode, I’d recommend downloading and installing the Sansa Firmware Updater at

http://www.sandisk.com/Retail/Default.aspx?CatID=1376, then connect your Clip.  If this doesn’t work, disconnect the Clip, go to the Settings menu and select Format, let it reformat, then connect it again.

thanks I will try this.  I am recording the Arkansas-LSU football game and will give it a try when we beat LSU  ( I hope)

gary

THANK YOU SOOOOO MUCH, Ive been sitting her RACKING MY BRAIN tryna figure out what is goin on with this thing, they do not have the proper support for this thing, geeez!!

Ladyberg02 wrote:

THANK YOU SOOOOO MUCH, Ive been sitting her RACKING MY BRAIN tryna figure out what is goin on with this thing, they do not have the proper support for this thing, geeez!!

I think Sandisk probably assumes that most people will sync the Clip via WMP, so they don’t provide information on MSC mode etc.  They do mention, in the Quick Start and Users’ guides, how to drag-and-drop music onto the Clip in MTP mode, although they forgot to mention the “Internal Memory” folder.

 

 

Thanks PP.  I had the same problem with MTP mode, and was ready to return the Clip to Best Buy.  The other mode allowed my computer to recognize the device.  Now, if only SanDisk had given sufficient documentation on installation and problems such as this!  I’m now ready to navigate through the troubled waters of updating firmware, charging, and using the features of this device (while holding my breath!).

Thanks again!

fiddlewaltzer wrote:
Thanks PP.  I had the same problem with MTP mode, and was ready to return the Clip to Best Buy.  The other mode allowed my computer to recognize the device.  Now, if only SanDisk had given sufficient documentation on installation and problems such as this!  I’m now ready to navigate through the troubled waters of updating firmware, charging, and using the features of this device (while holding my breath!).

You’re welcome!

 

If you have a PC that supports MTP, it is supposed to be easy … you just plug in your Clip, start up Windows Media Player and there you go.

 

Unfortunately, the installation of MTP can get corrupted on some people’s PCs … I guess I’m one of the lucky ones, it’s always worked without a problem for me.  Some people find that reinstalling WMP will fix their problems.

How about if you tried all the above mentioned things, and it still doesn’t work?  I updated my media player, downloaded the scandisk stuff and still no removable disk shows in my computer.  I have also tried locking the clip, holding the center button and pluging it in.  So far this Christmas I have spent half of it on the computer trying to get these working for my kids!

Any help would be appreciated!

Make sure you plug in the cable hard enough because the cable and the device’s port might not properly inserted which could be one of the problem.

purpleprincess wrote:

How about if you tried all the above mentioned things, and it still doesn’t work?  I updated my media player, downloaded the scandisk stuff and still no removable disk shows in my computer.  I have also tried locking the clip, holding the center button and pluging it in.  So far this Christmas I have spent half of it on the computer trying to get these working for my kids!

If you have the latest version of the firmware, you should be able to go to the “Settings” menu, select “USB Mode”, and then select “MSC”.  Then when you plug in the Clip (no holding the center button etc. needed), it should show up as a removable disk under My Computer.

 

If you don’t have the latest version of the firmware (you wouldn’t see “MSC” under the “USB Mode” menu), then download the Sansa Firmware Updater to get the latest version.  http://www.sandisk.com/Retail/Default.aspx?CatID=1376

How do you go about updating the Firmware if the computer doesn’t recognize that the device is plugged into the port?? I have no USB options under Settings.

Whenever I try to run the Firmware Update software, nothing happens. I assume it’s looking for the Sansa but not finding it due to Windows not recognizing it?

My machine is Vista Home Basic and MediaPlayer 11. Whenever I hook the Sansa up through any USB port, I get a popup saying:

USB Device Not Recognized

One of the USB devices attached to this computer has

malfunctioned, and Windows does not recognize it.

For assistance in solving this, click this

message.

I click the popup and the recomendation reads:

Try reconnecting the device. If Windows still does not recognize it, replace

the device.

The Sansa itself says Connected and shows full battery, even though the minute I unplug it from the USB it says low battery and then shuts off.

got mine figured out. It was a USB cord issue.

I’m happy someone has managed to get this thing working but I’m almost ready to chuck the whole thing out the window. 

I am computer ignorant and confess that I don’t understand most of the posted suggestions.  I have installed the Updater, done the multi-finger hold-push-plug but have no idea how one goes about finding out whether the machine has done what it was supposed to. 

My computer just won’t recognize it although the Clip says it is connected and there is an occasional ‘beep’ coming from the computer.  I have also tried to use the Menu button as I gather that is how one finds the ‘Settings’ option mentioned in a number of these threads…nothing. 

To complicate matters, my computer recently died and had to be reformatted…the Computer Nerd (real company name) guy did a basic re-installation and now my Windows XP won’t validate so I’m not sure if that is causing some of the problem - especially since I could not download WMP 11.1 which was mentioned as a possible solution to the Clip issue.  

Any further (eash to understand for computer novices) suggestions out there or should I just give up and hunt down a portable radio at the Pawn Shop?

I’m not sure what you have or haven’t done.  Try this.

1.  On the Clip, move the on switch (player’s left side) down, to the hold position.

2.  Connect the USB cable (not yet connected to your computer) to the Clip.

3.  Hold the Clip’s center button down as you plug the other end of the USB cable into your computer.

4.  At this point, you should be able to click open My Computer on your computer and there should be a drive there for the Clip.  Open it up.

5.  Go to the sticky above for the .18 firmware upgrade.  Get the firmware “bin” file that is provided there (if I recall correctly, it is in a zipped file, which you download to your computer, and then double-click and then follow the directions to unzip the bin file).  Drag and drop that bin file into your Clip folder that you opened up (but not into a folder within that folder).  Your firmware then will upgrade itself (if I recall correctly, you need to detach the USB cable for that to happen).

6.  At that point, you will have the most recent firmware on your player.  If your Clip will not connect up to your computer in the Clip’s “natural” mode (when you connect up, a Clip drive of some type should appear under My Computer), go to Settings/USB on your Clip when it is not connected to your computer, and choose MSC (mass storage capacity).  Your Clip now will function as a hard drive when it is attached to your computer.  You will be able to do everything you want with it, _except that _you won’t be able to play music and audio files protected by Digital Rights Management.  For DRM to work, you need at least Windows XP and SP2 on your computer, along with Windows Media Player 10 or above.

I hope this helps!

I’m not sure what you have or haven’t done.  Try this.

1.  On the Clip, move the on switch (player’s left side) down, to the hold position.

2.  Connect the USB cable (not yet connected to your computer) to the Clip.

3.  Hold the Clip’s center button down as you plug the other end of the USB cable into your computer.

4.  At this point, you should be able to click open My Computer on your computer and there should be a drive there for the Clip.  Open it up.

5.  Go to the sticky above for the .18 firmware upgrade.  Get the firmware “bin” file that is provided there (it is in a "zipped’ file (which ends in .zip), which you download to your computer and then double-click, and then follow the directions to unzip the zipped bin file to get the file ending in .bin).  Drag and drop that bin file into your Clip folder that you opened up (but not into a folder within that folder).  Your firmware then will upgrade itself once you disconnect the Clip from your computer, which you now should do. 

6.  At that point, you will have the most recent firmware on your player.  If your Clip will not connect up to your computer in the Clip’s “natural” mode (when you connect up via the USB cable, a Clip drive of some type should appear under My Computer on your computer), go to Settings on your Clip when it is not connected to your computer (press the little black button under the house symbol on the Clip, and press down on the Clip’s wheel until you get to Settings), choose USB Mode, and choose MSC (mass storage capacity).  Your Clip now will function as a hard drive when it is attached to your computer.  You will be able to do everything you want with it, _except that _you won’t be able to play music and audio files protected by Digital Rights Management.  For DRM to work, you need at least Windows XP and SP2 on your computer, along with Windows Media Player 10 or above.

You will know that everything is working when, after you connect your Clip to your computer, there is a Clip drive of some type under My Computer on your computer, that you can open up.  Also, Settings/Systems Info should say V01.01.18A (the most recent firmware, which you just installed).

I hope this helps!

I’m with you up to #4…I got an ‘E Drive’ for the SANSA M350 and then a screen popped up to download the “updater” which I did.  Now, in the E Drive, there are three folders consisting of Audible, Record, and Music.  Additionally, there are five files, one of which is the M300A bin file…

I’m not sure what to do next…gosh I’m so pathetic but am soooo appreciating your help!

you see the bin file is on there… now disconnect clip … done

Message Edited by amkoas on 01-05-2008 06:30 PM

It’s working!!!  I can’t thank you enough…it appears that I need not have opened that bottle of wine to drown my sorrows…shame to let it go to waste though so cheers to you both!

Ok, you’re doing great!  In fact, I think you’re there.  But let’s check some things.

1st, go into the Clip’s Settings (using the black button under the little house on the Clip), and down to System Info–does it say that you have the upgraded firmware ending in .18A?  I think it likely will, and what happened is that when you tried to upgrade before, you actually did, without knowing it.  That’s why you have the bin file still hanging around on your Clip (if I recall correctly, it disappears when you upgrade).  If that’s the case, you can just delete the bin file using your computer, to clean things up.

2nd, you didn’t need to install the Updater–some people don’t like it, as it “hangs around” on your computer, and then each time you plug your Clip into the computer, it goes out via the Internet (if you’re connected) to SanDisk to check and see if there is new firmware out there–if there is, it downloads and installs it.  But maybe you prefer that automatically to happen.  If you don’t want it around, you can go to the computer control panel (Start (lower left of the computer), Settings, Control panel), choose Add or remove programs, and then choose the Updater and uninstall it.

3rd, if you have the .18 firmware installed, you can go into Settings/USB mode, and you should have 3 choices:  Automatic detect (or something like that), MTP, and MSC.  Choose which one you want.  As mentioned elsewhere, the MTP and MSC modes are mutually exclusive and allow you to connect to different computers with differing capabilities.  That is, you can switch between the two modes depending on various computers’ needs (MSC mode is the more “universal” of the 2 modes) or leave the Clip in Auto mode and it will do this for you, and all music you put into your Clip will always be available for playing, but:  when you hook up to a computer in MTP mode, you only will see the files that were put onto your Clip while in MTP mode; and when you hook up to a computer in MSC mode, you only will see the files that were put onto your Clip while in MSC mode.  (In other words, you might only see part of your music at a time, while connected to your computer.)  Because of this, I set my USB setting to MSC mode.  From your description, I think you are connected in MSC mode right now, and so you may want to choose that mode.  The only thing you can’t do in MSC mode is use DRM files (like DRM protected files you purchase at certain websites).  If you don’t care about that, I’d choose MSC mode.  If you do care about this and if you purchase DRM protected music and books, you’re going to need to get your computer compliant with Windows XP SP2 and WMP 10 or above, the Clip’s requirements for DRM files and MTP mode.  (I think this is why you have been having issues:  your computer likely doesn’t have the required software right now.)

Ok, now you’re set.  Drag and drop some music files or entire folders into your Clip folder when you are connected to your computer (the music can go anywhere on your player, but the Music folder is a handy place, to keep things tidy). Then disconnect the Clip.  The Clip should now say something like, Building Database–that will take maybe a minute.  And then you can start using the player (see the instruction manual).  That’s all there is to it!

Message Edited by Miikerman on 01-05-2008 07:25 PM

Yes, I managed to get it to where I could select MSC mode…and did so in order to keep things simple.  My needs for this machine are very simple…I want to load some music onto it from my limited CD collection and also use the FM tuner… just some music to keep me distracted on the bus and during my runs…as previously mentioned, I am not great at this so I’m looking to keep it easy.  I asume that the MSC mode will be ok for these purposes?

One last question…I have connected the Clip to my computer to charge the battery…how long should this initial charge take?