getting computer to recognize sansa clip problem

You’re doing what I’m doing.  Again, if you don’t buy DRM music, no need for MTP mode.  And by chosing MSC mode on your player, you know that when you connect to any computer, you should be able to connect and you’ll always be seeing all the files on the player. 

(Note that there likely were 4 or 5 songs on your player to begin with, a gift from Sansa.  With my player, they only were visible on my computer when I connected to the computer in MTP mode.  You can just leave them on your player; delete them using your player, to free up the space; or connect to a computer in MTP mode, move them to your computer, disconnect your player and set back to MSC mode, re-connect to your computer, and move the songs back to your player, and now they will be visible on your computer when you connect your Clip in MSC mode.)

The Clip takes 3-4 hours to charge fully from empty; your charge will depend on how charged the Clip was to begin with.  Just leave it be for a few.  And then enjoy some more!  And it really is easy from here on out–just connect to your computer and drag and drop.

you gotta knack for stretching a 5 word answer into a speech… i aint hatin…:smiley:

Yeah, was thinking that myself.  But with someone who says upfront he doesn’t understand what’s going on, I think 5 words will just confuse more or cause issues later (when one doesn’t see half of one’s music, because of using the auto mode …).

Ok, I was reading what you told them to do for th sansa clip… My computers arent reading my sansa clip it will charge and says its connected but i have no icon in my computers, i’ve tried it on two comoputers… I tried the suggest of steps 1-4 on a previous page and nothing happened… I havent had my sansa clip very long i just got if for christmas… so any suggests will help out a great deal. thanks

lilian_brook wrote:

Ok, I was reading what you told them to do for th sansa clip… My computers arent reading my sansa clip it will charge and says its connected but i have no icon in my computers, i’ve tried it on two comoputers… I tried the suggest of steps 1-4 on a previous page and nothing happened… I havent had my sansa clip very long i just got if for christmas… so any suggests will help out a great deal. thanks

When you say “i have no icon in my computers”, do you mean that you’ve double-clicked on the My Computer icon on your desktop?

Message Edited by PromisedPlanet on 01-08-2008 02:33 PM

yes when i hook my mpe up the computer and click on my computer no icon for the mp3 shows up… it used to and now it doesnt… i get no message about usb port not working or nothing about unknow device… like some of the people on here… i get nothing.

Hi.  I am new to this site and to the Sansa Clip.  First of all, I want to thank you for the great explanation you’ve offered…I have a similar problem with my Sansa Clip, where my older computer would not recognize it.  I followed all the steps above to be able to see the Sansa Clip as a folder, upgraded the software, and selected MSC mode.  I have also succesfully copied a song that I downloaded from BestBuy Music Store (powered by Rhapsody) to the Sansa Clip.  The song is clearly there (I can see the artist folder, CD name and track name under the Sansa M350 folder in My Computer) and if I have the clip connected to the computer, it will play the track using BestBuy Music Store.  My problem, though, is that when I disconnect the Sansa Clip from the computer, the artist, CD name or track won’t show in the clip’s Music submenus.  However, all the music I placed inside of it previously (using the default mode, not MSC, but the other one) using a different computer, does show.  Why could this be?

Another piece of information: The track that I cannot play is in .rax file format (as downloaded from Rhapsody), whereas all other music is in mp3 format.  Could it be that the Sansa clip does not play .rax file format?  I would not think so, since the clip came with the BB Music Store software.

I appreciate any help that you guys can provide, and thank you for it (as well as for all the information I got from reading your previous communications).

First thing, your Sansa should display in My Computer as “Sansa Clip”, not “Sansa M350”.

My guess is that if the song (.rax) is a subscription song (contains DRM), you’ll need to load it onto the Clip in MTP mode, not MSC mode.  I’m not sure about this, though, as I’ve never attempted to load a DRM song onto a player in MSC mode. 

Message Edited by PromisedPlanet on 01-09-2008 08:49 AM

It first displayed in my older computer as Sansa M350 after connecting the USB cable while in Hold and pressing the center button on the face of the Sansa Clip.  Otherwise, the PC would not recognize the Sansa Clip at all.  After downloading the newest firmware and setting the Clip to MSC mode, this computer still displays the unit as Sansa M350.  

The problem with loading the file in MTP mode is that the computer does not see the Sansa Clip in that mode.  I suppose that I can try transferring the track to a computer that sees the Sansa Clip in MTP mode, then copy/pase the track into the Sansa Clip from that computer.  I’ll try that tomorrow and let you know if the Sansa Clip shows the track then.


Sansa Clip does not play RAX format.  You need to convert it to WMA DRM within the Rhapsody application.  An alternative is to burn a and Rip it back to MP3 or WMA.

I finally got my Clip to work! I updated the firmware and reinstalled WMP 11. With Clip in AutoDetect and WMP11 open, I plugged in and shazam. It loaded up MTP and successfully transferred and played DRM WMA.

so i have a somewhat similar problem

my sansa clip has been working fine for a month and recently i plugged it into a mac which i think is my main mistake but im not sure.

now when i plug it in, my computer (windows xp) will only recognize it in msc mode.

the difference is that when the clip is unplugged , it will freeze right when it displays SanDisk the second you turn it on

actually it will freeze whenever it is not plugged in to my computer or if it is plugged in, it will freeze at the same SanDisk display. (this is only when it is NOT in msc mode when you plug it in)

if it is in msc mode, and you unplug it from the computer, it freezes at Connecting with the computer/musicplayer display and the arrows in between.

so basically, you can add music and stuff only if it is in msc mode, but when you take it out, the whole thing freezes, which just makes the

whole player useless.

i’ve already tried updating the firmware but the moment i disconnect the player from my computer it freezes at “Firmware upgrade in progress”

im going crazy with trying to find a way to fix this and i dont want to throw it away either

any suggestion would be greatly appreciated!!!

Try going into all the folders on the Clip (in MSC mode) and deleting any remaining Mac OS filesystem garbage, such as “dot named” files and folders such as".Trashes", “.DS_Store”, “.Temporary Items”, etc.

Could be one of these mucking up the Clip when it boots and goes to refresh the database and encounters certain Mac stuff.

If you could, try deleting just ONE file/folder name type at a time (i.e., purge instances of “.Trashes” first), then unplug the Clip and see what makes it happy again, with the goal of discovering (and telling us) what causes it to be unhappy. Mac OS drops lots of strange files and folders on MSC devices, some of it is likely handled by the Clip, but Sansa may have missed something important.

If you do get it going, I’d drop the newest firmware on it right away. You could even connect it back to your Mac and see if the same OS junk causes the same problem, with the new FW.

By doing this and reporting your findings, you will be helping many users as well as giving the development team at Sansa a heads up. Believe me, they pay attention to this forum, and have corrected many issues due to user reports, and there’s reportedly a new firmware due out by March.

Things like this are preventing the Clip from achieving it’s rightful place as the iPod Shuffle Killer :wink:

Good luck!

IT FINALLY WORKS !!! Sandisk Tech support had me do the following: -          Turn it OFF-          Put it in the HOLD position-          HOLD the center button IN while plugging into USB port, continue to hold for 5 to 7 sec even after plugged in.At this point MY COMPUTER recognized it. And it worked. He also had me to: - go to MICROSOFT.COM- In the upper right hand search bar, type in MTP PORTING KITI did this and downloaded the first one. Now my Sansa Clip work perfect. I wish I would have talked to him last week before I returned the last one, for the same reasons. If this does not help call the 1-800 # , opt #4, and ask for GUY (yes that is really his name) out of 5 or so calls to Tech Support he is the only one who knew what he was doing, and how to actually HELP.

GOOD LUCK             ( you also must have / download windows media player 11)

Hi, I’m very grateful for all the answers posted here because they saved me countless hours getting my Sansa clip connected - I had to set it to MSC mode, and now I can use Windows Explorer to move music.

I do have a new problem now, and would appreciate any help - I moved some songs onto the clip, but it only recognizes one of them and it is MPEG Layer 3 Audio format song. The others that I moved are MPEG-4 Audio files, and the Sansa does not see them as being on the clip. However, when I plug it back into the computer, I can open the Sansa directory from my computer and all those MPEG-4 songs are on it. From the Sansa menu, it says I only have one song loaded… Just in case this is relevant information, I have iTunes set up on my computer, and my other players are all iPods, and I don’t really want to mess up all that, that’s why I’m moving songs using the Windows Explorer and not using WMP.

Thanks in advance for your help.

the supported filetypes are mp3 and wma, not mpeg4. Those files will not work on your clip and will need to be converted to a supported file format. ipods are the only ones that play that particular file format.

Is there a way to convert the MPEG4 files without actually losing the original MPEG4s? I want to keep my iPods working, but I’m afraid that if I install another software to convert music to MP3 format, I’ll lose everything in iTunes?

Also, the Sansa player does not play the audible files I moved to it. The menu shows that I have 3 audiobooks on the player, but they are all listed as “unknown”, and when I try to play one, nothing happens. 

Thank you! 

using a converter to convert the mp4’s should not delete the original mp4. If they have a license on them, making a copy like that is going to be a bit harder. Some people go as far as to burn the songs onto a blank cd and rip it again in the mp3 file format.

They are showing up as unknown because of the id3 tags. id3 tags are what the player uses to recognize all of those various fields, artist, genre, album, etc…

To edit these fields, you can use various programs and software. Windows Explorer, Windows media player, media monkey, mp3tag are just some examples of software that can edit the id3 tags. You can read more about it in “FAQs” (Frequently Asked Questions) section. There is a sticky about it.

Hey! Yep I have the same problem…but I dunno if this will work…but if you put your songs on a flashdrive and then put it into the folder. How exactly did u get the clip to be recognized by your computer? Please respond, hope this tip works!

I am sorry, but what if on my computer it doesn’t recognize this device, but on another it does? i downloaded whatever the link was but it didn’t work…so yeah…please help thanx