Frequently Asked Question (FAQs)

Exclusive to Sansa Clip:

  1. Using Your Sansa Clip with Your Mac, Including a Script for Exporting iTunes Playlists

General FAQ’s that apply to a various portable mp3 devices

  1. What is MSC and MTP and how do I change it?
  2. Show Hidden Files and Folders / Music folder is hidden in MSC mode, what do I do?
  3. “Not enough space for MusicDB, Please free …” error message appears on the Sansa player
  4. I am having problems installing MTP drivers, what should I do!?
  5. How to create & modify M3U playlist to work under MSC mode using only WMP10
  6. Creating .m3uPlaylist on Linux
  7. How to rip CD contents directly to your player using WMP10
  8. Tutorial for Using Rhapsody
  9. Fixing Bad Files / Running Check Disk

Always adding more, feel free to make suggestions for FAQ’s in a new thread.

PM me if any mistakes are spotted, thanks.

Best Regards,

Mr.SmileyFace

Message Edited by MrSmileyFace on 03-05-2008 03:23 PM

Message Edited by microsansa on 01-25-2010 10:22 PM

Dear Mr. Smiley Face,

I bought my Sansa Clip 4 Gb silver today just to record my voice. No, I am not a supremacist, just a lecturer who wants to distribute my worldy knowledge to my students via email, or by putting my lectures on a memory stick for them.

No, I am not presently interested in music downloads or even using the Free Rhapsody inane tunes that came with the CD. My question is:

Can I use this baby without subscribing to Rhapsody or even using the CD?

Thanks,

Folklife:manhappy:

Message Edited by folklife on 07-10-2008 02:51 PM

Absolutely!  Just drag and drop away.  The CD is not needed at all (and many did not receive a CD with their Clip).

Enjoy, and educate your students!

Smiley Face,

I would like to download a voice recording as well, but I cannot figure out how to do this with windows media.  Can you help?

I just bought the Sansa Clip 4 GB.  When I slide the power switch (below the usb port) down it does not shut off, nor could I find any other way to turn it off.  What am I missing here?  I came back to it a half-hour later and it was off, but it seems like the battery is going to go down fast if it won’t turn off right away.

Any help you can offer would be appreciated.

Greg

User’s Guide (pg. 7)

Indeed, the manual is always handy, especially a cool pdf version like the SanDisk ones.

Just for fun, I checked it out again.  The POWER switch slider is also described in page 6 of the pdf (actually page 4 of the book).  The Clip’s power switch has several functions.

Sliding it UP to the ON position for about two seconds will turn off the player, and in cases where it freezes, a soft reset can be performed by holding the switch in the ON position for 10-15 seconds.

When in the bottom position (orange), this is the lock position, preventing accidental key commands. 

Bob  :smileyvery-happy:

My brother tried to use his sansa clip on an Apple computer…the idiot…and now it doesnt do anything…is there a way to reboot the clip to do more than turn on when being charged?..would hate to lose a perfectly good clip cause he was an idiot…or is it fried?

Connect the Clip to a Windows PC in MSC mode:  manually force the mode by starting with the Clip OFF.  Slide the power switch down to the HOLD / LOCK position (orange showing).

Hold the center button depressed while plugging in to the PC, until it displays “connected” on the display.

Now let’s remove the “applasauce” from the device.

Open a Windows Explorer window via My Computer or press [Windows Key] + E.  Do you see the Clip listed under “devices with removable storage”?  Make note of the drive letter assigned to the Clip.

Now, open a command window by going to Run > enter cmd and enter, or the shortcut [Windows Key] + R.

Let’s assume that the clip is mounted as device E:

From the command prompt in the box, type chkdsk e: /f where “e” is the drive letter you found assigned, and /f is a “toggle”, telling chkdsk to "fix the errors found.  When chkdsk asks you if you would like to save the garbage found as files, tell it no.

Now, a wee bit of surgery.  Close the MSDOS window for now (yes, fellow propellerheads, you can do the following in old school DOS if you so desire.  Please apply an appropriate anti-rust agent like Liquid Wrench as needed.)  Well, for everyone else, do not apply lubricants or anti-corrosives to your Clip.

Format the device by right clicking on the Clip in the Explorer window and select Format.  DO NOT use “quick format”.  If your device is larger than 2GB we’ll need FAT32.

Yes, formatting erases all data from the Clip, so you’ll need to reload afterwards.

Right click on the device and select Eject.

Unplug, and see if it starts up normally once again! Slide the power switch back up.

If not, you can connect again in MSC mode, and reinstall the firmware as described in the firmware thread.

Bob  :smileyvery-happy:

dumb question - what is the “applasauce”?

and when I try to chkdsk w/ the clip still in - i get access denied

and when I try to chkdsk w/ the clip out - i get cannot open volume for direct access

but so far you have gotten me further than anything else…any ideas…or am i doing something wrong still…like maybe using my office computer?..should i wait til i get home?

Message Edited by re_cad_monkey on 12-09-2008 11:59 AM

The applesauce is the host of wee garbage characters that the Apple likes to fill the Sansa with.

Did you attempt formatting with the Apple?  It will try to overwrite the data area in its own format.

The idea here is to get the Clip in a state where it ignores the data area (and subsequently won’t hang up on the database refresh), allowing you to go to Settings > Format > Yes on the Clip itself.

Let me know how it goes!

Bob  :wink:

@re_cad_monkey wrote:

and when I try to chkdsk w/ the clip still in - i get access denied

 

Are you sure your Clip is in MSC mode (not MTP of Auto-Defect)

 

and when I try to chkdsk w/ the clip out - i get cannot open volume for direct access

 

Well, Duhhh . . . if it’s not connected, how do you expect ChkDsk to run on it? :stuck_out_tongue:

@re_cad_monkey wrote:

and when I try to chkdsk w/ the clip still in - i get access denied

 

Are you sure your Clip is in MSC mode (not MTP or Auto-Defect)

 

and when I try to chkdsk w/ the clip out - i get cannot open volume for direct access

 

Well, Duhhh . . . if it’s not connected, how do you expect ChkDsk to run on it? :stuck_out_tongue:

got it!!..apparently instructions work great from home…not so much from work…now if i could just find my keys…life would be back to normal…thanks for your help!!

I got my music from my mac with no problem, so what’s the deal? Does this mean I can’t switch to using a PC later, or am I missing something? The music sounds fine- I can listen to it using the earbuds, so I know it is.

Also, I am trying to use some speakers that are hooked up to my computer to play my sansa clip- NOT through the computer. Can this be done? I bought an auxiliary audio cable that says that it should work, but it’s not. It has a mini plug that fits where the headphone jack goes and a plug that looks exactly the same that should go in the speakers headphone jack? Any ideas?  

The speakers’ headphone jack is for ouput, not for input. You’ll have to connect the speakers’ input cable to the Clip to use it as a source (assuming, of course, the speakers’ input is a standard 3.5mm jack; I don’t know what Macs use for output).

thank you:)

Mr. Smiley,

I have a question that I don’t think has been addressed here as yet.  When I access my Clip (8mb, v. 02.01.16A firmware) in Windows Explorer I see different file content depending on whether the USB setting is set to MSC or MTP.

For instance, when set to MTP, I can see all of the various music albums tucked nicely in the Music folder but, while showing the folder (and subfolder) for my Overdrive audiobook, none of the files are actually there. 

Conversly, when set to MSC, only a couple of the album subfolders are in the Music folder and the audiobook, and it’s actual files are present (but not tucked in the subfolder like I placed them).

I haven’t been able to replicate the interaction between the player and my PC sufficiently to draw any theory.  I’ve tried changing the sequence of starting software (Overdrive, Windows Explorer, WMP 11) and plugging in Clip in varied combinations, but no luck.  It’s very strange how this thing acts.

Also, FWIW, I was able to dowload my first Overdriv book and listen only to the first four parts after which the player sought some DRM permissions required by downloading via appropriate software.  NG after that.  Very odd.

Thanks for any help,

MJK

Your computer shows the files transferred to the Clip in the same USB mode that the Clip currently is set to; hence, IMHO, a good reason to use one USB mode for the Clip consistently. 

I have a spanish language course that I have loaded into my Clip lessons one through 32

when the lessons play it plays 1-5 then 30 31 32 then 10 and so on

I have the lessons as Audio (1000) through audio (1031)