Firmware update w/ rockbox installed

Ok so I got myself in a bit of a problem.

I had rockbox installed on my device for 6 months, and all of a sudden my tracks began skipping 20 seconds into the song. I wanted to check to see if it was rockbox causing the problem, so I tried to boot into the sansa firmware. No luck - the player just hung up and I had to reset. I tried to uninstall rockbox, but to get rid of the rockbox bootloader, one must perform a sansa firmware update.

Problem is, the sansa updater won’t recognize my player. And when I copy the clppa.bin file into the player’s root directory, the player doesn’t update. I just boot back into rockbox. And as said before, I’m unable to boot into the sansa firmware for some reason that the guys over at the rockbox forum can’t help me out with. 

I’ve tried reformatting the disk by creating a new partition to no luck. I’m worried that I deleted some essential files in the root directory - there were a series of empty folders (ie ##MUSIC##) and some .sys files that were present that got wiped out. 

Anyone have any tips or advice? The player is essentiall unusable right now.

Have you tried both Version 1 and Version 2 of the Clip firmware installed manually? Only one will work with your player.

Otherwise, if the Rockbox geniuses can’t solve it, the thing may be bricked.

I don’t understand reformatting by creating a new partition. If you connect to your computer and do a Windows FAT32 partition it should just erase user files (music, podcasts, etc.) If you somehow got into the Clip’s system partition and destroyed stuff…hard to say.

Thank you! I did not realize that there are two separate versions of the firmware.

The one I have used is on the link at

Where can I find the other version??


Oop, sorry to raise false hopes. The old Clip has two versions. The Clip+ only has one, which you’ve got.

You do know that you have to press and hold the back/rewind button while bootinig to boot into the Sansa firmware, right? I would do this with the player off, while at the same time plugging it into your computer. YOu should then be able to download the firmware file (it’s a .zip file; don’t forget to extract it first) to the root (uppermost) directory and when you unplug from the computer, it should install the firmware.

Yup, my problem is anytime I do that, the player hangs up and won’t turn on. I’ll have to reset to get the player to start up again. This happens when I’m connecting via USB and also when I turn the player on. I used to be able to do this no problem in the past, I don’t know why it’s freezing up now…

If both firmwares are failing, the flash memory is probably pretty screwed up.  Assuming the flash is not complete broken, formatting should fix it:

You should be able to mount the player in the rockbox bootloader USB mode, reformat, and then boot into the sandisk firmware.  

Thank you very much!! Tried formatting, and was able to reformat, but the player still lights up saying “Plug USB cable”. Again, I can turn it off, but am not able to boot back into sansa firmware. So I’m just stuck in rockbox USB mode.

Thats normal.  You have to either reinstall the sandisk firmware, or reinstall rockbox after you formatted.  

Maybe I misunderstood, do you mean that after formatting it still crashes when loading the sandisk firmware?  

I’ve got rockbox deleted now, so when I turn the player on, rockbox tries to boot, says file not found, and goes into “Bootloader USB mode”

After reformatting and unmounting the disk, the same thing happens - rockbox tries to boot, file not found, player goes into rockbox USB mode.

If I try to boot into sansa firmware by holding left and the power button, the player won’t turn on at all. After releasing both buttons, and just pressing power, the player still won’t turn on. I have to hold the power button down for 30 seconds or so (reset) before I can get back into the rockbox USB mode. The sansa firmare updater does not recognize the player, even though Sansa Clip+ shows up in windows when I have the player mounted.

It seems like I need to boot into the sansa firmware to complete reomve the rockbox bootloader, but I’m not able to do that. 

Don’t press the power button. With the player off, press and hold the left (REW) button. At the same time, plug the player into your computer. Continue holding the left button. It should boot into the Sansa MSC mode. Then you can manually re-install the firmware. Don’t use the Updater. Go to the firmware thread/post here on the forum and download the appropriate f/w .zip file and extract it to your computer where you can find it easily, like your Desktop.

Once extracted, drag (or copy) the extracted .bin file to the player. Once copied (it will only take a second or two; the file isn’t that big), unplug the player. The firmware will start to install, then the player will turn off. Press the power button to turn it on and the install will finish. You will then have to select your Region and your player will have no remnants of Rockbox bootloader.

Ahhh, I tried doing that, but the player won’t connect or turn on at all while holding down the left button. Really similar to trying to boot into the Sansa firmware by holding left and powering on. 

It seems like the player freezes everytime I try to boot/connect in the sansa firmware. If I can get around this, I think the I’ll have a straightforward way to fix the player.

Have you tried connecting while holding the center button? 

Yes, it connects in the rockbox USB mode. When I disconnect, it boots back into rockbox, and thus never installs the sansa firmware.

If you can get it recognized as the Clip you should be able to drag over the Sansa firmware (unzipped) onto that driveletter.