Just deleted Rockbox firmware and can't return to stock one [Clip +]

Hi, i installed Rockbox using installer provided in THIS link. I didn’t like it. Using same program i uninstalled Rockbox folder, but not bootloader file. Program couldn’t delete it on this specific device. I proceed to use auto-update-installer provided by SanDisk HERE. I can’t tell, which Sansa’s revision do i have and can’t check it due to “no file found / plug in USB cable” message. Auto-update didn’t work neither for rev 1 nor rev 2. Neither did puting files manually. Can someone help me with this problem? 

I will gladly provide more information, if anyone will need it for further debugging.

You’re in the right church, but the wrong pew. :smileyvery-happy:

Your 2nd link goes to the firmware for the “original” Clip, not the Clip+. Click here for the correct one. Follow the manual install instructions for re-applying the SanDisk firmware without the modified Rockbox bootloader in it and you should be back in business. :wink:

Don’t use the Updater.

Almost there, but…

“without the modified Rockbox bootloader in it [in Root]”. And this Rockbox-bootloader-responsible-file is…? I’ve tried running, previously deleted separatlly:




(even hidden) DID.BIN

Everytime after plugging off Sansa displays “file not found” and few secs later “PLUG USB CABLE”.

HERE’S, how my Sansa’s root looks like.

Sorry… I read somewhere, that if i format whole Sansa disc and then put only clppa.bin inside, it would work. It didn’t… Is there any way to reinstall stock firmware?

Are you following the manual firmware upgrade instructions that Tapeworm links to above?

Yes, i am. I put clppa.bin into root directory. Path to this file is now F:\clppa.bin. F is my Sansa’s drive letter. There is no other file there. I formatted it. But still have backup of files i deleted. I plug Sansa off, then “no file found” message appears/ Next “Plug USB cable”. When i plug in, screen displays “Bootloader USB mode”.

Ok, now i am at Rockbox again… It works well. But i really need to go back to stock firmware. Can someone guide me? Putting mentioned .bin files in stock directory doesn’t work at all. 

Have you read the various posts and instructions on this at Rockbox.org . . . ?

The Rockbox manual for the player covers this, and uninstallation can be done both manually as well as automatically with the Rockbox Utility.  See p. 17 of the manual.


Thanks for the linked. Once i had Rockbox installed, i was able to boot into original firmware by holding POWER+LEFT simultaneously. It worked! First, there was Sansa’s logo, next “Updating firmware” and it booted successfuly. Then I restarted device and it turned into Rockbox again. I uninstalled Rockbox using Rocbox Utility but again i was not able to delete bottloader! It is “not supported on my version of device”. It tells me to “take usuall procedure of updating firmware to delete bootloader”. I don’t get it! I have just done it. Do you happen to know, which file is responsible for choosing, which software to boot? If so, please, share this file with me, if running stock firmware.

From manual:

Copy an unmodified original firmware to your player, and then reboot into the Sandisk firmware.

I have tried it. It didn’t work. “file not found” it said.

@janjakjur wrote:

From manual:

Copy an unmodified original firmware to your player, and then reboot into the Sandisk firmware.

I have tried it. It didn’t work. “file not found” it said.

You first have to boot into the SanDisk OF by pressing the left (REW) button during startup. Then manually copy a fresh version of the original firmware to the player, linked to in my previous response. Unplug, and the fw will install itself and everything shold be fine from then on.

And THIS is what i needed. It is not specified ANYWHERE, that i should copy, while running stock firmware. Thank you, sir, very much!

Of course, SanDisk wouldn’t add that step, because it’s thinking of things under its own firmware and system, and not under Rockbox.  ;)  But you’re right, would be good for Rockbox to note and clarify that.

Glad it worked for you!

From the rockbox manual:

2.5.2. Manual Uninstallation
Copy an unmodified original firmware to your player, and then reboot into the Sandisk
firmware. See section 3.1.3 (page 20) for more information.

Thank you again, everyone :slight_smile: