Sansa clip + NO FILES AT ALL

Hi, I’ve recently bough a sansa clip +, and I read that it was a million times better with Rockbox, so I decided to downloaded. When I tried to put it onto the sansa it would just keep on telling me that there was no mountpoint found. Well thats not the point.

I read the, that i should format the sansa and that when i plug it to my windows computer to press the centre button.

I did this and now I have my sansa with literraly no files in it, its true that it still works with rockbox but my doubt is: CAN I RETRIEVE THE OROGINAL SANDISK FIRMWARE?? hOW SHOULD I DO THAT? I TRIED DOWNLOADING THE UPDATER, BUT BECAUSE IT HAS NOTHING IN IT, IT DOESN’T SO A THING.

Thank you for you support, sorry for any mistakes i might have but a im from Spain and my english  isn’t that good.


First of all, you should get the Rockbox manual so you have it to consult.

You probably still have original Sansa firmware on there and can still boot into it.  Try turning it off and holding down the left (<) button as you turn it on.

If that gets you to the original Sansa firmware, good. 

The Sansa Updater is not necessary. You should uninstall it from your computer.

 Look at the Firmware thread near the top of the page and search for “manual installation.” Basically you download a zipped file, unzip it on your computer and drag the unzipped file or folder (I forget) onto the driveletter of the Sansa . (If your Sansa shows up as E: SANSA FUZE, then just copy the unzipped stuff onto E:). Disconnect and the firmware will get intstalled.

Here’s how to uninstall Rockbox: