Formatted Sansa Clip, Bad Move!

I formatted my clip+ via Windows and of coarse like a fool that emptied every file in the the clip+. I downloaded the clip firmware

but every time I opened up the zip file titled clppa, it just opend another zip file titled clppa.bin.  I thought it was supposed to open up some other type of files.  Anyways, I put the [latter] zip file into the clip+ with no results. I have the clip plugged in and

all it says on the screen  “bootloader usb mode” and when I unplug it all it says is “file not found” and “plug into usb”.

How do I get the normal files back into the Clip+ because that directory is non-existant Now.  My bad.

Try pasting the “clppa.bin” file into the empty root directory of your Clip+ device.  Then use the eject command in the Windws tool bar. 

Thanks for trying to help but that did nothing at all!

First off, formatting the player will not erase the firmware, but it sounds like you might have Rockbox installed; do you? I believe formatting WILL delete Rockbox, except for the dual bootloader which is actually modified into the Sansa firmware when you install Rockbox.

This dual bootloader allows you to boot into either rockbox or Sansa (original) firmware via button presses. It will boot into rockbox by default. If this is what happened, your player is trying to boot into rockbox, but can’t find the file (since it’s be deleted). You will have to to boot into the Sansa ‘side’ (by holding the rewind button, if I recall correctly) during start-up, then plug to your computer . Then you will be able to copy the .bin file to the root directory & update (reapply) the firmware (minus the dual bootloader).

Once this is done, your player will be basically back to factory status. If you want Rockbox again, you will have to re-install it.


Thanks tapeworm that worked wonderfully. I appreciate all your help, you made my day.

Glad it worked for you! :smiley:

Hi Tapeworm,

I was reading a post of yours earlier but can’t find it again. I formatted my SanDisk Clip Sport using Ubuntu, using a type of format that didn’t say it was compatible with everything, and now I don’t understand how to drag the hex file into the root directory that I downloaded via your post to regain use. Did I delete the root directory? The San Disk does not show up in the “Computer” section of my computer, only if I open “Disks.” Please help! I’m not a computer person but am pretty good at following directions when I can find then :stuck_out_tongue: I just want to be able to use the device again, which reads “file system error. restart or format to recovery.” Restarting does not solve anything. Thanks!

Nice answers, thank for an advice!