External hard drive and ExpressCache

Has anyone had a problem using external hard drives with ExpressCache. I find that ExpressCach is constantly reading from my external hard drives, which means I cannot eject the hard drive because I get an error message sying drive is in use. Thanks.

1 Like

The same happens to me. The interface should have a tick box of drives to cache AND defrag.

Still, it might be possible to exclude drives via prompt with eccmd.

@Centurion and others,

Good point!

I am using an external USB 3.0 HDD full-time.

Are you saying that I would not be able to use ReadyCache without incident?

If it is a problem does anyone know if this is in the software *Bug List* to be corrected or is it hardware?

Really important!



I would like to request an offical SanDisk response to my above post.

Thank you.

I also use external HDDs all the time. I do a lot of photoshop work and keep photos on various external HDDs. Everything seems to function ok as far as working with the drives. Only thing is that the ExpressCache is constantly accessing the drives.

This causes 2 problems:

  1. Cannot eject a drive through Windows because it says the drive is in use. So if I want to unplug a drive and plug in another, the only safe thing is to shut the computer down. Not a deal breaker, but certainly inconvenient.

  2. Since the drives are constantly in use, I don’t know whether this will have any effect on the life of the drives.

I am using ExpressCache version . I have tried to do research on this matter, and have not been able to find much.

Also, if I disable ExpressCache, everything turns back to normal with the external HDD.

And I guess I have the same question with the main HDD. With ExpressCache constantly accessing it does this have any effect on the life of the drive?

Would really like to hear from others on this subject. Thanks.

I also would be appreciative of a official response from ScanDisk.

In answer to the OP, yes I too have had issues relating to removing external hard drives.

I found due to the large capacity of the external HD, and various visited folders within, the Sandisk Expresscache software will not release the external HD when I ‘remove the USB device’. Requesting a PC shut-down, the PC/ laptop takes ages to shut-down (cup of tea time) only to find the Expresscache software has been reset on restart.

Could this be a potential problem when attaching mobile phones as storage, haven’t tried and don’t intend to but, it may be something else to consider when testing/ updating.

As previously said, a tick box to ignore caching on external media may in fact be the simplest answer, after all, it’s caching for the Operating System and program files from the primary hard-drive.

I wait in anticipation of the next release

RoRo, yes exactly my problem. My EHH is only 1 TB.

Also, notice now that ExpressCache is constantly accessing my primary hard drive with significant activity. Been doing so for a couple of days, even if I leave the computer on but inactive all night.

I am concerned that the longevity of the drives will be significantly reduced.

If I disable ExpressCache at start up, all problems go away, so I know it is ExpressCache.

To be honest, I do not see any real performance benefit with ExpressCache and because of the issues, will probably just leave it off until SanDisk does something to solve the problem 

Does anyone know if I can just reformat the drive wilth Windows to make it an accessable drive and just use it as a 2nd hard drive?

Yes just reformat and give it a new volume. I did this to mine and just switch my page file to it for now or just use as a second drive. Had to many problem with the ready cache software for now.

Thanks Chas488,

Yes, I too am frustrated with the ExpressCache software. Also disappointed in the lack of response from SanDisk.

If you don’t mind offering me some assistance. If I go to Disk Management and select the ReadyCache SSD disk, the format option is greyed out. Do I have to delete the volume first, then format, then…? Thanks in advance. 

Did you uninstall the ready cache software? Delete  the drives partition,formatt and make new volume

from what i understand the expresscache software should ignore any external drive marked as removable. Are your External HDD marked as removable disks or fixed disks when you look at them in windows explorer?

Chas488, thanks for your help. Looks like I just need to delete the volume first. I think I will just use this for my photoshop scratch drive and maybe try again next time ExpressCache gets updated.


they show up as Local Disk, not removable storage. I was under the impression that External USB Harddrives always showed up as local drives, but only things like flash drives showed up as removable. These are just WD 1tb external USB drives.


I am not using the ReadyCache product…

However, I’m using a Maxtor External USB drive which is formatted as NTFS.

It shows up as a Local Disk.


Well ExpressCache 1.3.0 has been installed and the same issue still happens when removing the ‘removable USB device’ external hard drive (WD 1023). Checked USB HD for system/ surface errors and viruses using AVG and nothing.

Anyone else still encountering this problem?

Hm, I will try the external drive later when I get mine back:P

So far usb flash drives don’t have issues…but they shouldn’t defrag regardless.

Taking defrag control away should have come with some options to exclude…I"d like to exclude my media drives for instance, no reason to defrag those all the time.

ExpressCache version 1.3.0 DOES NOT cache or defrag any USB drives regardless if they are are defined as Removable or Fixed. It will only cache and defrag SATA drives.

Update: After uninstalling USB device and restarting the PC, I attached the external H/Drive and windows installed the device.

After this procedure I can now remove the USB device with Expresscache running. :smileyvery-happy:

The previous errors in removing USB device have now disappeared which must have been corrupt USB driver files and from the results, not the ExpressCache software. All running well!

Here is a link to the utility which can remove USB devices on the fly for re-installation if anyone else is stuck with this:


This not true is my system. I’ve just plugged a phone configured as mass storage via USB to copy some files (that I presume that were also cached), and the Safely Remove’ icon under the taskbar refused to remove it, saying that the device was in use by a program. After killing ExpressCache.exe via taskmanager, it could be instantly removed without any error.

I’ve faced the same behaviour too with a regular flash pen drive under 1.3.0.