ExpressCache doesnt work properly "%0 Caching problem"


I really need serious help

ExpressCache’s blue curves stays at &0 forever and doesnt work. But program itself says “caching”

According to my boot counter I made 25 boots since I install the program.

Sandisk readycache drive is NOT in dynamic mode

It doesnt have any partition on it

system sees the disk and its healty.

My C drive is also a SSD sandisk drive by the way.

Can someone help me how to make this Expresscache function properly? 

This sounds like your hard drives are “Dynamic”, are your other drives in “Basic” mode (other than your C: which is SSD)

Also you should see a partition in your readycache drive, you can use eccmd.exe -partition to create one.

wow what a tough challenge to make this thing work properly. But I didnt succeed.

I tried diskpart clean OK

            eccmd -partition  ERROR CODE 0xb7  !!

later i tried to create partition manually (read from  a forum) by using MACDISK utilty. I created HFS+ partition. but no solution sandisk expresscache couldt detect the drive this time

I go to disk manager deleted the disk - reinstall sandisk expresscache. This the only way sandisk expresscache identifies the disk and start working but caching is always 0 !! and 0.07gb problem

I tried the command eccmd -preload c:\windows

this is working. sandisk readycache started filling this time (so everything works)

eccmd -info --this is working list of disk and everything i s clear on screen

EC Cache Info

Mounted : Yes
Partition Size : 29.82 G
Reserved Size : 3.00 MB
Volume Size : 29.82 G
Total Used Size : 76.25 M
Total Free Space : 29.74 G
Used Data Size : 0 Bytes
Used Data Size on Disk : 67.75 M

Cache Stats

Cache Volume Drive Number : 1
Total Read Count : 24778
Total Read Size : 1.19 GB
Total Cache Read Count : 0
Total Cache Read Size : 0 Bytes
Total Write Count : 3460
Total Write Size : 79.45 M
Total Cache Write Count : 0
Total Cache Write Size : 0 Bytes

Cache Read Percent : 0.00%
Cache Write Percent : 0.00%

eccmd -partition this doesnt work (how come this command doesnt work since all is ok!! )

C:\Windows\system32>eccmd -partition
ExpressCache Command Version
Copyright® 2010-2014 Condusiv Technologies.
Date Time: 10/7/2015 17:41:7:727 (PIERCE #2)

**ERROR** ECCmd exited with error 0xb7 (183)


But again and again there is no caching

I gave my hours to make this thing work but no success 

How many drives are connected to the computer? Just the SSD C Drive and the readycache? If so it will never cache anything because the C drive is an SSD. This solution is for HDD + readycache SSD for caching. Your C drive is already on an SSD so there is not need to cache anything on it. 

if you have other HDD connected to the computer make sure they are not dynamic disk and you would ahve to access data or run programs that are stored on or installed on the HDD before any caching will occur. 

1 Like

Yes my C drive is sandisk ultra 2 ssd. And it’s a i5 notebook. readycache is installed via a hdd caddy from cd rom slot. And there is no another hdd.

So you say ready cache will not work on this situation right?

My aim was to decrease boot time below 20 seconds.

correct Expresscache will not cache anything if the system drive is an SSD. the Ultra II is a higher performance SSD than the readycache SSD so if you cached anything to the readycache ssd it would actually be slower than if you run it directly from the Ultra II ssd. The ExpressCache software is designed to ignore any SSD as caching will not provide any additional performance boost. 

Thanks drlucky for the info.