Expresscache STILL won't work! (Windows 8) - SOLVED

Got a Sandisk 32GB SSD for Christmas and was at the time using Vista as my OS, it told me that I needed to upgrade to windows 7, I was just about to and then I read that expresscache worked fine on Windows 8, so I brought Windows 8 because it was cheaper. I installed the SSD and then I went to install the software (this was on a fresh Windows 8 install), after installing/restarting the software had a bar that went all the way to the end but then restarted, it just kept doing it, another thread on here mentioned a similar problem with Windows 7. I tried compatability mode/reinstalling it multiple times to no avail. I then decided to wait for new drivers, I heard they came out yesterday and that they had Windows 8 support, so I just tried to install ExpressCache again and ran into the exact same issue, compatability mode or no, the only difference was that this time it opened an Expresscache window (over the window with the bar that kept getting to the end and restarting) that has a quesiton mark on it that had options such as “search for updates” etc (tried all of them and none of them worked, some of them just made it freeze). I really don’t know what to do here, anyone here have any suggestions? I am nearing the point of just formatting it and using it for other purposes/with other software, in my opinion this is a little bit of a joke since I have heard of people talking about similar problems since October.

what version of EC are you using? A new version was just released last Friday and in the release notes it says similar issues should be resolved. 

Well as far as I am aware the latest version (the one that you download from this site), it didn’t have any information of what version it was but when installing it, it still said “2012” instead of “2013” which made me wonder. If someone could give me a direct link, one that clearly showed it is the latest version would be great.

it will be downloaded from the same link as it uses the same installer. latest version is 1.1.0 and you can check the version by clicking the “?” in the GUI and selecting about or info cant remember exactly what it salys. 

http://kb.sandisk.com/app/answers/detail/a_id/9711/

*OP update

I tried following that guy’s instructions and came accross the exact same error, it installs, I restart, the bar goes on forever but an expresscache window loads up, in the window is just a white background and a question mark, when I click it options come up, nothing happens after clicking ANY of the options, some even cause it to freeze. I’ve installed it 3 times all with the same result. This sucks, someone help me.

EC uses core components of Internet Explorer do decode the HTML for the GUI. I have seen reports where if IE was uninstalled or the security settings were set to high similar issues could occur. Can you try resetting IE security settings to default and see if that helps? Or if you PC does not have IE installed install IE 8 or higher. 

I have windows 8, this comes with IE 10 as a standard, I remember deleting a shortcut for IE at one point but I have checked and it is installed (though not my default browser), my windows security settings are all turned off (they suck), that IE security thing sounds like it might be right but I have no idea how to go about changing it, any sugguestions?

to change IE security settings go to tools > options > security tab >reset all

That said another user had a very similar issue and found it was caused by an issue with active x. here is a link to what worked for him. can you try and see if it works for you?

http://forums.sandisk.com/t5/SanDisk-ReadyCache-SSD/Abnormal-error-running-ExpressCache/m-p/291763/highlight/true#M286 

It worked! Thanks guys, you can say what you want about this software but at least I eventually got to the bottom of this problem