Dear God I need Sansa Fuze wont install

I am a bit slow when it comes to new electronic devices but I know my way around a computer somewhat. Like many others it would appear that I am not the only one who received a Fuze for Christmas and are now overcome with issues. Any help here would be greatly greatly appreciated.

Here is my error message when I plu the Fuze into my USB port:

USB Device not recognized:

One of the USB devices attached to this computer has malfunctioned and Windows does not recognize it.

For assistance…blah blah blah

I am using Windows XP, I followed the advice on the official Sansa help site…I installed the new Media Player 11…installed the other little suggestions on there (all but the one pertaining to Vista) and still the same error message.

The player worked fine when I first opened it so it was functioning, unfortunately I left the player connected to the PC for three hours thinking it was charging when in fact it was not, so not my battery is dead and the player will only turn on when connected. All it shows when plugged in is a Connected screen with the arrows going around, then it proceeds to cut off and on trying to install itself?..I have tried both the front and rear USB ports but always the same thing.

If someone would be so very kind as to give me a step by step on how to remedy this problem would be awesome. My sister gave me this thing as a gift and I dont want to hurt he feelings by mentioning there is something wrong. It is my first ever MP3 player and I am pretty much clueless here.

Thanks in advance to any helpful soul out there who would be gracious enough to lend me a hand here.  

OK. Well the first thing you could check out… Is Drivers on your computer. GO to Controll pannel > System> Device Manager> and with the fuze plugged in scroll down to The USB ports. If any of these have a yellow triangle on them, you need to reinstall the drivers. What Service pack are you using?

Try msc mode

Did what you said…there is a yellow exclamation next to USB mass storage device. Oddly enough it appears that when I plugged in the player this time…for some reason…it shows my settings screen and is now apparently charging again because it has a bolt of lightening next to the battery icon.

Im sure I will sound like a complete twit here but I really dont know how to get to MSC mode or what that really means. Can you explain?

  1. First check what USB mode the Fuze is in “Settings -> System Settings -> USB Mode”, change it MSC.
  2. Check Windows device manager “Start -> Control Panel -> System -> Hardware -> Device manager -> Disk drives”, see if there is the Sansa device there.
  3. What Service Pack do you have installed? Go back to the “General” tab from the step above.
  4. Your sister would be offended if there was a manufacturing fault on the Fuze caused by workers in China?

I checked under disc drives and there is showing a ST340014A there…is that it?

The service pack is XP Professional version 2002 service pack 2

That’s your hard drive the yellow icon means that a device is not working rght click on it and select uninstall  then at the top you should see refresh looks like a pc with a wrench

msc is a mode that makes you mp3 player act a s a flash drive it allows to use your player without wmp 

MSC mode is in settings under usb mode

I also got the player into MSC mode. It seems that it is still not being accepted by Windows but the player seems to at least be working now in some form.

@jonelliott1976 wrote:
The service pack is XP Professional version 2002 service pack 2

Just FYI microsoft released a Service pack 3 for XP. Try to download that.

@jonelliott1976 wrote:
I checked under disc drives and there is showing a ST340014A there…is that it?

No, it would read “SanDisk Sansa Fuze XGB USB Device”. There should be 2 of them, one is the internal memory the other is the card slot.

Did you change the USB mode to MSC? What version of firmware do you have on the Fuze? (Settings -> System Settings -> Info. The top line is the firmware version. Mine is V02.01.17P)

It says version V01.01.11A

OK so I clicked on the uninstall USB device with the ywllow exlamation on it but it didnt give me any wrench icon or any option thereafter. What now?

go into device manager and uninstall all the devices that have a yellow mark

Done…all remaining devices are good.

Does that mean your fuze works now?

You can try charging it up first, by connecting in MSC mode manually.  This way, you can start with a charged Fuze.

Open a Windows Explorer window by pressing the [Windows key] + E, or go to My Computer.

Starting with the Fuze OFF, slide the power switch to the HOLD position (orange showing).  Press and hold the center button down while connecting to the USB port.  You should hear the familiar ba-ding sound as the device is recognized, and it should show up on the screen.  At this point, release the button.

This will allow the Fuze to charge: have a look at the battery icon.  It should be strobing.  Connecting in MSC mode is an easier task for the Fuze.  In this mode, it’s seen as a flash drive.  I suspect that the MTP mode might be your problem.

When the Fuze cannot establish a connection, it can get distracted from the charging operation.  It’s best to charge it before working on the MTP part of the equation.  Once it’s charging, you can slide the HOLD switch back to the center position.

Bob  :stuck_out_tongue:

I just plugged it back in, it attempted to install, gave me the same error message as before. Then it said new hardware found, then it said new mass storage device found, then it said new hardware found but with errors…device may not work properly. Now I have a new yellow exclamation on the same device as before in my USB listing.

I am starting to hate my new Sansa player  :frowning: