USB Device Not Recognized (Error message)

I got my Sansa Fuze 4GB in Dec and it’s worked fine until yesterday.  Now I get the “USB Device Not Recognized” error message whenever I try to connect it.   It won’t charge on my computer.

I’m running Windows XP,  Windows Media Player 11.  I tried switching between MSC + MTP  USB modes but that doesn’t work.

I haven’t had a reply yet.

Have you tried different USB ports or removing it in Device Manager, reboot then plugging in again?

“Have you tried different USB ports or removing it in Device Manager, reboot then plugging in again?”

Yes, tried back and front ports.

It shows up as “Unknown Device” on Device Manager under “Universal Serial Bus controllers.”  I uninstalled it, rebooted and plugged in again and it still shows up as “Unknown Device.”  When I click “update driver,” it says “Cannot Continue the Hardware Update Wizard.” 

Currently, it Fuze battery appears to recharge very slowly and sporadically.  The screen doesn’t give any indication that it recharges though. 

Did you try connecting it to a different computer, preferrably with a different OS (for example Ubuntu)?

Just to check that the problem is not within your Sansa Fuze.

I won’t be able to connect it to a computer soon but I don’t think that’s the problem.  I’m able to recharge the player abit.

Is there another solution?  I bought it at Best Buy 3 months ago.  Maybe I should just go there for an exchange?

You could try reverting back to Windows Media Player 10. Some have had success with this vs. WMP 11, but if it’s only 3 months old, I’d be heading back to Best Buy if I were you. Walk out with a brand-new player. Done and over with.

So I just returned from Best Buy with a new Fuze and I plugged it in…and the same problem happens.

Should I just return and get an MP3 by another company?  Any recommendations?

And overall might I have this problem if I get say a Sony MP3?  Or could there be something wrong with my computer?

Message Edited by SunnyW on 04-19-2010 07:12 PM

I’ve been fighting with this with my 2 month old Fuze for a week or so now. It does it on 3 different computers. It seems to take a long time before it’s recognized in Windows. I used Deoxit on the plug and connector but it didn’t improve anything. It takes about 30-45 minutes after plugging it ito the USB port that it pops up as a drive in Windows.

it seems like alot of people are having this issue

has anyone ask microsoft about this problem?

All was well but I also got the same problem.

http://forums.sandisk.com/sansa/board/message?board.id=sansafuse&message.id=41772&jump=true

Are our dear little Fuzes getting spooked by Microsoft :dizzy_face:

If the Fuze isn’t getting recognized you need to:

Switch to MSC mode. (Settings/System Settings/USB).

Connect directly (no hub).

Try on another computer. 

Log on as Administrator.

Try (temporarily) turning off antivirus or internet security programs in case they are blocking access.

Look for the exclamation point in Device Manager, uninstall, reboot and reconnect. 

If none of that works, specify what operating  system you are using. And copy your exact error message.

he’s tried that

if you clicked on the link you would know

There are 3 people complaining about this problem. BlueMax has been clear, the others…? ?

I have XP with SP3 running on all my computers with no problems with the Fuze. But you never know what Windows is up to. 

There are step-by-steps here:

http://kb.sandisk.com/app/answers/detail/a_id/42/session/L3NpZC9UdFNtVDItag%3D%3D/sno/0

Some people have reported magically wonderful results by installing the MTP Porting Kit from support.microsoft.com .

Message Edited by Black-Rectangle on 04-22-2010 09:17 AM

I dowloaded and MTP Porting Kit once again rebooted the PC, re-set the Fuze and connected it up

no joy. 

tried MTP, MSC and auto-detect modes, making sure to disconnect the Fuze everytime.

no joy.

If the someting showed up in the device manager, I could have re-installed the drivers.

But as it is I don’t know the name of the drivers and which directory I can find them.

 Does anyone know?

Also, does anyone know of changes made to the registry entries when Fuze or ‘update manager’ is used for the first time?

Thanks

My last message here:  I got fed up after my 2nd (brand new) Fuze wouldn’t work.  Went to Best Buy and exchanged it for a 8GB Sony NWZ-E344.  They had a sale on it last week so I was able to exchange it straight up.  The Sony has had no problems so far.   It has a 30 hour battery life.  The negative is that it doesn’t have the Fuze wheel but other than that, it connects to the computer easily.  Good luck!