Sansa Fuze+ not recognized by Windows 7 (it's not the cable or computer!)

Hi all,

My wife and I both have a Sansa Fuze+ and generally love them. Hers has been working fine but all of a sudden it stopped being recognized by her computer, as she was about to try copying some music to it. I suspect a corrupted driver on the device but can’t figure out how to get it fixed if the computer won’t see it.


  1. The player is functioning fine, playing music, menus working, etc. When we plug it into the USB port it charges but is not seen by the computer as a connected device (i.e. no “Connected” screen on the Fuze).

  2. It’s not the computer. My Fuze (and my kid’s) work fine on the same computer.

  3. It’s not the cable. Our other players work fine on this cable. Also tried different cables just for kicks - no change.

  4. Tried her Fuze on 3 different computers (Windows 7), none of which are seeing it. My Fuze is seen by all of them.

  5. Presumably it’s not the USB port on the device, because it charges up fine using the same port.

  6. Tried changing the USB Settings on the player from auto-detect to MTP and MSC – no change on any of them.

So I figured something’s wrong on the device, and tried resetting/formatting it to see if I could then update the drivers/firmware or the like. Formatting worked as expected but it’s still not seen by any computer. Also tried fiddling around in Windows device manager and such, but it’s just invisible.  So how can i update the device if nothing can see it? (For example the Sansa Updater software just says “please plug in a device to proceed” … never sees it.)

I’m hoping there’s some other trick I haven’t thought of, beyond buying a replacement or having it repaired. If anyone has any suggestions I’d be greatly in your debt! Thanks.

Update! Minutes after posting this I noticed something I had missed — apparently the trouble Fuze is NOT charging when plugged into a computer or the wall outlet. There’s definitely some signal getting through the USB port, because if the Fuze is turned off and I plug it into my computer, it turns on. But it seems like the USB port is not functioning correctly at all. Send it in for repairs?


You can try the force MSC mode from the player and see if it works then.

Here is the link to it:MSC mode
If nothing works then you should contact SanDisk technical support for a replacement.