Brand New Sansa Fuze Not Recognized by Computer

I think I had this problem with my old Fuze, but for the life of me I can’t remember how it got fixed. My old Fuze died. 5 months after I bought it, the thing stoped being able to charge. After a big annoying hassle, I got the company to send me a new one. Mind you, this is the SECOND time I’ve had to replace the Fuze due to some internal problem that was not my fault, so you can imagine how thrilled I am to have an issue…AGAIN.

So I hope that you nice people can help me fix this problem so I don’t have to call up customer support again. Especially since it is the holiday season and I know they’re probably swamped already.

Here’s the problem: when I plug the charger cable into the USB port of my computer, the computer gives me an error message saying that the device is not recognized. Nor am I able to find it listed at all under My Computer. I have tried to reformat. I have tried switching the USB mode. I have also tried the soft reset (holding the power for 15-20 seconds). I have tried restarting my computer. I have even tried using a different computer, but the problem remains the same. The Sansa Updater is useless since my computer can’t see the device. All of my drivers are updated and working properly. The USB drive recognized other devices (IE: memory sticks) without any problems. 

What else can I try? 

Without being recongnized by the computer, the Fuze cannot even charge. When it is plugged in, it will show the charging icon for 2-3 seconds before it disappears. This will continue on and off several times a minute. The Fuze does have about a 70% charge that it came to me with. 

I am really getting fed up with Sansa. If this problem doesn’t get fixed soon…or if I EVER have another issue with this thing I am going to get my money back and switch to a different company’s product. Somebody please help. I have never had such bad luck with electronics before :frowning:

UPDATE: I have finally gotten the Fuze to be recognized by my gf’s computer so it can charge, but I still need to figure out why my computer doesn’t recognize the player. All my music is on my computer and with 20+ gig, it would be really hard to transfer to hers. 

Message Edited by CirrusMoth on 12-25-2009 08:54 PM

What operating system?

My first guess is that your device is in MTP mode or in automatic USB detection mode. Now that I’ve picked up quite a few Fuzes over the past month, I have a routine I do when I first plug in.

First off, I make sure the particular USB port I want to use works with a variety of items. This eliminates the first chain of problems.

Secondly, I make sure the USB/Fuze cable is working, normally by using it with a known-good Fuze. This might be hard if you have only the one cable, but since the cable works on your GF’s machine, it’s likely not the cable.

Lastly, I connect in a way that ensures I know how the connection works.

I turn the Fuze power switch completely off, so the little dot is visible.

I hold the left arrow side of the wheel down on the Fuze.

While holding it down, I plug in the cable.

This forces MSC mode during the initial connection.

Every Fuze I’ve gotten my hands on (and, at this point, I own more than 12) has been through this, and only two have not responded to this.

My first thought would be that there is something up with your USB port, especially if the Fuze works on the USB port of your GF’s computer. I’m sure you’re plugging it in thoroughly, but maybe you can try turning off your machine and switching USB plugs around.

My second thought is that something is up with the cable, and that you’re putting it in a different position when using your computer than when you’re using your GF’s computer. If there’s a broken wire in it, that could cause it to give that inconsistent reaction.

Of course, it’s really impossible to know exactly what you are doing unless you post every little step. All I can do is try to rule things out. I shouldn’t even assume that you and your GF are using the same operating system, which is a useful detail to know.

OS: Windows XP

The computer is 4 years old now and was custom built by a company no longer in business (or I would ask them for advice as well).

Do you want any of the other specs?

Make absolutely sure it is in MSC mode. Windows XP came with Windows Media Player 9, and the Fuze in MTP mode wants WMP 10 at least. 

Try every USB port. No hubs. The charging and then disconnecting suggests the Fuze isn’t getting enough power from the USB port. 

When it’s connected but not connecting, you can also try going into Device Manager (Right-click on My Computer/Manage/System Tools/Device Manager)  to see if there is a yellow triangle with an exclamation point–probably in USB controllers–and Uninstall it and reboot, to see if the USB driver needs repair. 

I’m not really sure what you mean by “the little dot” when the Fuze switch is turned off, but I tried your suggestion. No luck.

I have multiple USB ports on my tower (2 in front, 2 in back), with the same result for each one.

Somtimes when plugging in the Fuze I get an error message: “a problem occurred during hardware instellation. Your new hardware might not work properly.” This is followed by another error about windows not working right with it. Sometimes I can get the folder for the Fuze to show up briefly, but it always closes on its own after a couple of seconds. 

 Unless the Fuze shows up under My Computer, I can’t manually change the firmware or anything like that. 

I feel really stupid having such an issue with this thing, but it’s becoming very frustrating.

I have Windows Media Player 11.

There are no errors with any of my drivers. I am leery about uninstalling any of them because I have a storage expansion directly installed inside and I don’t want to accidentally skrew something up I can’t fix and lose access to 80 gig worth of stored files. If I uninstall a driver, can I be sure I can get it back without a hitch?

Go to Settings then to USB then make sure to choose MSC.  Pretty sure it will work.  By the way my Sansa Fuze is going back to Csotco inthe AM…these things suck!

EDIT: Hmm, I just noticed on the SanDisk page linked below that it wants Windows XP SP2. Have you updated your XP at least that far? 

I agree, don’t uninstall drivers if they are working. 

Can you see your firmware version in Settings/System Settings/Info? I just gave someone a new Fuze and it was already 2.02.26a, nice and recent. Firmware shouldn’t make any difference to the USB connection anyway. 

For what it’s worth, you could set a Restore Point (under Accessories/System Tools in XP) before monkeying around, and Windows keeps a set of original drivers to reinstall (at bootup) anything internal that has been uninstalled, but I’d only uninstall if I saw the yellow triangle. 

The “driver not found” business is usually a problem with MTP mode, so make sure you’re in MSC.

Search down this SanDisk page for “admin” in case you have run into an eccentricity of some Windows installations. 

Then again, you may just have a bad cord. Have you tried your old Fuze cord? Or it may be a bad unit. Call 1-866-SANDISK, even if they are swamped, and have them walk you through their steps, and if it doesn’t work, exchange it.  

I do wonder if so many USB ports is making them all lower-powered,  especially on a custom computer. That means you’d just be out of luck. But a connection to the USB port that’s closest to the power source in your computer, probably on the back, should theoretically work. 

Message Edited by Black-Rectangle on 12-26-2009 07:07 AM

And I keep this UMDF thread around for really inexplicable situations. 

Some people have reported an issue with connecting the Fuze in MTP mode on a PC with Windows XP SP3. Apparantly after SP3 was installed, Windows Media Player needs to be uninstalled and reinstalled for the Fuze(and Clip or Clip+) to be able to connect in MTP mode. I have had this problem as well. Rather than uninstalling and reinstalling Windows Media Player, I use MSC mode for connecting my players to my pc.

I didn’t consider that it might be Windows Media Player. I do have SP3…so who knows? I know the mode chage didn’t help, so I’ll try reinstalling the player. I am also looking for my old cable as well, but I’m not really sure when I put the thing. Not sure if it will help since this is the problem I had with my old player, but who knows?

Thank you for all the help!