Can't get my laptop to recognize my Sansa c200 anymore. what happened?

Wanted to transfer some music to my laptop. Plugged in my Sansa and got nothing.  The ports on my laptop recognize anything else i plug in like microphone, speakers, mouse, keyboards, etc.  just not the Sansa.  Thought it may be a firmware issue but that didn’t do anything. 

Anyone else have this issue?



Having the same issue. Below are two of the generic answers SanDisk provides. Let me know if it helps you. It did not help me. 


I had the same problem on my desktop, fixed it yesterday.  I’m running Win 7.  First I made sure everything was up to date.  I did have to install an update with a new service pack.  But it still didn’t work after that.

Then I came across instructions for changing the device from MTP mode to MSC.  I was a little concerned since I had never done anything like that.  But nothing else had worked, so I tried it.  And it worked!  Go here for details on the process I followed

See the post by JeanneB  on 6/25/11 at 5:32am.

Make that “from MPT” to MSC.

You had it right the first time. It’s MTP.