To those of you who can't get your computer to recognize your C250...

Try going into Settings, scroll down to “USB”, unclick “Auto Detect” and click on “MSC” instead. 

Make sure you save this setting by using the white button (center), then click on Menu to go back to the beginning.

Also, I turned on “Smart Playlist” and “Advanced” under “Settings” as well…not sure what that does or if it helps with this problem or not.

Finally, be sure to click on the “Safely Remove Hardware” icon in your system tray before disconnecting you MP3 player.

My M250 is working like a champ now whereas before I couldn’t get the PC to recognize the new hardware at all.

Hope this helps some of you.

BTW, I just bought mine from Circuit City on 9/1/07 and the firmware is 4.1.07A.

Based upon all the complaints I’m reading here, I won’t be updating anything as long as it works like it does now.

im pretty sure that version 4 firmware is for m200s, not c200s

Under settings I have Equalizer Power Display Language FM Settings Volume System Info Reset All Format No USB! How do I get to USB? My model is Sansa c250. System info says Version is 01.01.05P I downloaded the updater. It says no updates for my model. I can load mp3’s into it with winamp. Format is my only option to delete anything.

you have the versionj .05 firmware, its autodetect. It doesnt give you an option for USB. You can call sandisk and ask them to email you firmware to roll it back, although it should work just fine. A lot of people debate that they want a choice, but I dont see what you cant do on the player in MTP that they do in MSC.

take a look at sansamonster’s post at the top of this forum about how to access MSC mode in the .05 firmware…

bit of good news for some people…

u can still do MSC in 1.01.05…

here are the steps:

  1. Make sure your c200 is ON

  2. Slide the HOLD button to the right (towards the “rec” button, you’ll see an orange color)

  3. While pressing the “rewind” button “|<<” plug the device  to your PC, wait until you get confirmation that your device is recognized.

hope this helps.

btw, this also works on c200 v2 version.

Message Edited by sansamonsta on 09-05-2007 05:05 PM

hey, danch_lukens, where do you have “Advanced” and “Smart Playlist” in your settings?

Using the tip that just posted, I got my player into MSC mode. Thanks for that tip! Enigma, help me out. In MTP mode, I can use the supplied software to load photos into the player. But now I want to delete one of them. How can I do that in MTP mode? In MTP mode, my expansion card got screwed up and thought it was full, but the database refresh would not find any of the MP3’s I loaded into it. The internal format command does not format the expansion card. I need to format my expansion card to get the space back. How can I do that in MTP mode? I want to display an album cover when an MP3 is playing. How can I do that in MTP mode? The instructions for updating the firmware says to put the device into MSC mode. Well, I want to update the firmware. How can I do that in MTP mode? If there is a way to delete photos, format the expansion card, display album covers, and upgrade the firmware all in MTP mode, please help me to find the docs and then I can live with an MTP-only mode device. I suspect that all of this must be possible or SanDisk would not have disabled MSC mode. But I can’t find out how. (And no fair telling me to avoid putting photos in the expansion slot and then use “format” to delete a photo. I want to delete a single photo, leaving everything else untouched.)

my goodness, space out your issues or bullet them. I’m sure ill probably miss one of your concerns. When you connect your player, and you open it up in my computer you will see “audio device” before anything else.

When you open “audio device” you should see 2 drives, internal and external, you can right-click on eithier one to format it. This process was always the same. If you dont have a card in the player, you wont see the external drive.

If you have the .05P firmware, then you have the latest and the updater isnt going to do anything for you. If you want to roll-back, you would have to ethier a. get the files from sandisk after they email it out. or B. follow the instructions on some of the other threads. You should be able to connect your player in MTP mode, and have the auto updater still notify you that updates are available when they are. The express works in MTP mode only and it works with the updater, theres no reason that this player cant do the same in MTP mode only.

And in regards to the album art, I would have to player with it. Im not even positive you can view pictures from the card on the player. My e200 doesn’t let me do that. If someone beats me to it, even better.

If you are trying to delete something from the player itself, just one file, and cant find it to delete it. The most I can suggest is to un-hide files and folders as well as operating system files. After exploring the drive, you are still unable to find what you need, personally, I would format it and start over. Its easier then me sitting there and looking for one individual file. I find after reloading it on there, I can find it without a problem.  It should be noted that I have only ever run into a scenario like that maybe once or twice, I usually find the file… even if I cant find it at first.

First, sorry about the formatting. I’m new here and have not found my way around completely. I had formated my post but it was squished up by the forum software. Let me try html codes.

OK, on preview, that does look like it’s working. I am surprised that the forum is allowing me to code in html.

As for the C250, I must suspect that you have not, ummm, upgraded to the latest firmware. I am using XP sevice pack 2 with all patches applied, but when I connect my C250 in MTP mode, it does not show up in My Computer. I can use WinAmp to move MP3’s in and out. And I can use the supplied application to move photos in but not out. I can not find any other way of communicating with the C250. My MTP mode is nowhere near as functional as yours is.

If you are using a lower version of the firmware, please don’t upgrade to run any experiments on my behalf. It’s not worth it. I have un-installed the firmware updater to ensure that I don’t have to endure any further “upgrades”. Now that I can get into MSC mode, it is working good enough and I can live with the current level of functionality.

If you can’t get ‘My Computer’ to recognize your MP3, here is something that works for me. Also works for our other mp3 player (different make).
Go to the control panel and right click on ‘Portable Media Devices’ and choose ‘create shortcut’ from the menu. You will be told that you can’t have a shortcut in the control panel, but it will create one on the desktop, which is what I wanted anyway. Connect your MP3 to the USB. Open the new shortcut on the desktop to find an icon for your player. The first thing I got was a ‘Needs an updated driver’ message, but I ignored that, at least for now. Double click the Sansa icon to find two folders, Data and Media. Open media, this is where your files are. Now you can drag and drop into any of the folders, or delete unwanted files as you wish. Hope this helps

Mine is the latest firmware. But I can roll back with no problem since I had sandisk email me the files. It should be working in all the aspects you said it wasnt working. Just roll back to bring your msc mode easier to resort to.

I’m glad everyone got theirs working. None of that fixed mine. I can not get a connection as long as it shows unrecognized.

I have no portable Media Devices in control panel. How does one downgrade firmware if they can’t get a connection?



if the computer is not recognizeing your device, it cant downgrade the firmware.

does your computer see the player in msc mode? what version of wmp do you have installed? (if you upgrade from 9 to 10 or 11 then it will isntall mtp drivers)

I’m useing MP11. I used it yesterday and it worked fine. Today it doesn’t. I can’t get it recognized in any mode. I even tried that service mode or whatever it’s called where you hold-record-menu.

I have an RMA request in, and they have already started working with me, so I’ll back burner this until that has run it’s course. This apparently isn’t the same firmware issue everyone else is talking about, since mine is 01.00.06A.