DO NOT DOWNLOAD LAST FIRMWARE UPDATE!!!

The option to change MSC and MTP is missing!!! How could I get previous firmware back? HEEELP…PLEASE

It’s 01.01.06F

Hello

Actually i upgraded my c200 a few hours ago. As well i didnt find MSC Mode anymore. It is
not possible anymore to connect with the upgrade tool because it says: MTP…please change…
There is no possibility to change…like already said…

the system is 01.01.01E

and now i have around 805 TB on my 2GB Player and Format doesn’t work anymore.
Startup takes around 5 minutes.

So what to do now?

sorry meant

System is 01.01.05E …sorry

sorry.mine is 01.01.05F too

AND I CAN’T PUT MY MUSIC IN EITHER OUT OF MY C250…HEEELP MEEE PLEASE

fully ACK…impossible to put anything on it…

it probaly switches it to auto-detect, i think all the players are going to be like this. Just like the express and the connect.

call sandisk and ask them to email you older firmware maybe?

When I did my last firmware update, I got 01.01.00P, which is what is listed on the website as the latest update for the c200 series.  When did you guys get a .05 version?

For heaven’s sake DO NOT update your Sansa c240 firmware to V.05. You’ll be VERY disappointed unless you like iPods. If it’s too late ask your local support people to provide a link to or email you the 04 version. 

I, definately, agree that the latest firmware update was a HUGE step backward! It removed much of the control that I had over how the device works and has made it a very disappointing unit, for me. I’m having problems getting MP3 files, from a CD to transfer to the C250 and, as from the beginning, having a real problem with getting playlists to work as one would expect.

Come-on, Sandisk, make this thing work the way most users would want it to, intuitively!!!

For me it was not a HUGE Step…it BRICKED my c250. It runs yes. But startup 5min.
Radio removed. No MSC anymore possible…so no update possible. No transfer of
Mp3 anymore possible (neither way)…No records possible …It sais full but hasnt anything on it.
Memory sais things from betwenn -210… (Integer.MIN_VALUE) up to 80TB.
Formating fails…(Hopefully i still have warranty on this brick)

For gods sake…dont update anything!!!

Is there an actual problem in transferring files, or getting the device recognized? Or just the fact one mode is gone that you were used to?

The ver2 devices already come with firmware with no USB options, and upon plug in Windows XP pops up the request what to do with it - just select to open it in Windows Explorer if you want it treated like a drive.

It can be treated exactly like a drive, but it’s not given a drive letter. All folders are available, music, recordings, pictures, album art, playlists, ect. You can copy into the folders and delete.

The packaging says Windows Media Player 11 is required, but I never used it. Just copied files over from the folders they were in.

If you do use WMP, then your syncing will work too.

>Is there an actual problem in transferring files, or getting the device recognized? Or just the fact one mode is gone >that you were used to?

Yes. Yes and No . No
The Player is recogniced as MTP Thing…thats it. Using WMP submitting files doesnt work because it isnt recognized anymore.
The updater (firmware) wants to work…but tells
“Please unplug your device and switch to MSC mode if you want to check for updates.”
Well…i cant…

>The ver2 devices already come with firmware with no USB options, and upon plug in Windows XP pops up the >request what to do with it - just select to open it in Windows Explorer if you want it treated like a drive.

there was an USB option. so i guess it was ver1. Yes, there is a pop up…chose WMP or do nothing…
Actually the same so far.

>It can be treated exactly like a drive, but it’s not given a drive letter. All folders are available, music, recordings, >pictures, album art, playlists, ect. You can copy into the folders and delete.

I know. It was EXACTLY like this BEFORE the update. Now it is not recognized. Neither on XP nore on Linux.

>Just copied files over from the folders they were in.

I want tooooo. :frowning:

>If you do use WMP, then your syncing will work too.

Dont like it, but tried it several times on differnet machines with different WMP…nothing

so far …i have said all i know about this…
I hope it will preserve other users from this mess…
reagards

I think its terrible that sandisk dont tell what there updates do or fix.

They want us to update, but you never know what you get.

I have never seen this before from any other company.

I really dont’t know what happened, but as I connected my c250 few minutes ago, everyting was OK. Everything works. New mode is something between MTP and MSC. You can synchronize it fith WMP or use it like an HD by Windows explorer. I really don’t know what happend but I’m absolutelly pleased.

again, its like the express or the connect. Its switched it to Auto-Detect. It assumes you can use MTP, and if that doesnt work it switches to MSC. You can still use all the normal functions you did before… as far as i know anyway. My relative has this player and was confuzzled at first as well…

I’m still very confused as to when all of you got this .05 version of the firmware.  I updated only about a week ago, and what I got was 01.01.00P, which is what is listed on the website as the latest (not that corporate websites can be relied upon for being updated reliably).  (Unless they rolled it back due to customer problems)

So, when did you folks update last?

I think I found the answer to my question based on when sansamonster posted his thread with the latest version numbers. 

I think Joe_Silencio should email Sansa if his radio disappeared - sounds like he got the wrong firmware downloaded.

Crap. My files don’t show up in Windows Explorer. When I check the ‘drive’ properties, it shows my c250 mostly full (which it is), but I can’t see filename so that I can delete them. The new firmware did nothing except remove my USB options. Has anyone got any kind of response from San Disk on this firmware debacle?