Sansa e260 not recognized?

My laptop isn’t recognizing my SanDisk. It’ll charge when plugged in but I can’t add or remove music. Any idea how to fix this? It’s only on that one laptop.

MSC or MTP mode?  IIRC you need the latest version of WMP (and maybe service pack) to use MTP mode on a lot of Windows versions.  

MSC should just work on any version though.

I should have clarified, I just recently had trouble installing anti-virus software and after I removed it my player stopped connecting. It worked fine before that. I don’t know how to fix this? It’s in MTP mode I believe. It’s not showing up on the computer at all, all I can do is charge it. I have tried Microsoft FixIt which corrected my D drive problems but did not fix my player’s connection. The player is not listed anywhere, not under device manager, Windows Media Player, or under my anti-virus settings.

If your antiirus screwed up Windows, I’d probably do a repair install of Windows.  Usually thats the easiest way to fix that kind of problem.