Audio Book Order on the clip+

I purchased a sansa clip plus recently, primarily for listening to audio book.  And I LOVED it.  I liked it so much that I got my wife one.  Then we ran into a problem with the way audio books are played.

We both have a Sansa Clip Plus with firmware V01.02.15A and we copy audio books to the SANSA in MSC mode.

BUT, I use linux.  It appears that linux always copies the files in alphabetical order.  My wife uses windows, and windows does NOT always copy files in alphabetical order.

And thus the problem with the sansa clip audio book playback that *I* did not notice.  Within a book (as determined by the album tag) It orders the chapters by the order in which they were copied to the player.  It does NOT order them by the filename.  It does NOT order them by the title tag.  It does NOT order them by the track tag.   I was able to reproduce this problem on my player in linux by deliberatly copying the files out of order.  I reproduced this problem with different books, and on both players.

So, for example, If I have an audiobook on my computer that looks like this:

Folder:Godwin_SpacePrison

    * spaceprison_01_godwin_64kb.mp3
    * spaceprison_02_godwin_64kb.mp3
    * spaceprison_03_godwin_64kb.mp3
    * spaceprison_04_godwin_64kb.mp3

Then I plug in the sansa clip plus, and under AudioBooks create the same folder, then copy in the files out of order:

Folder:/media/SANSA CLIPP/AUDIOBOOKS/Godwin_SpacePrison

    * spaceprison_04_godwin_64kb.mp3
    * spaceprison_02_godwin_64kb.mp3
    * spaceprison_01_godwin_64kb.mp3
    * spaceprison_03_godwin_64kb.mp3

Once I disconnect the player, the chapters will appear on the sansa in the order in which they were copied.  4,2,1,3.   It does not sort them by filenamet or title or track!

Like I said, on linux this isn’t a problem because (at least in all of my tests so far) if I copy a folder (or even just a selection of chapters) and paste them to the sansa, it copies them in alphabetical order.  But if I boot into windows xp on my machine, or windows 7 on my wife’s machine, and do a mass copy/paste, the order in which they are copied is not entirely alphabetic and the sansa plays the chapters out of order.

Of course, the simple fix for this is for my wife to copy one chapter at a time to the sansa, but that is annoying.  And it just seems strange that the sansa wouldn’t sort by filename or tag?

(and the problem would ALSO dissapear if I could convince my wife to use LINUX!) :slight_smile:

From scanning the forums it appears that this is NOT a new problem:
http://forums.sandisk.com/t5/Clip-Clip/Sort-Order/m-p/141857/highlight/true#M29448
http://forums.sandisk.com/t5/Clip-Clip/Audiobook-Sort-Order/m-p/96076/highlight/true#M13959
http://forums.sandisk.com/t5/Clip-Clip/Wrong-song-ordering-on-my-Sansa/m-p/112335/highlight/true#M16166
http://forums.sandisk.com/t5/Clip-Clip/Sansa-Clip-8-gb-wrong-track-order/m-p/117242/highlight/true#M24220
http://forums.sandisk.com/t5/Clip-Clip/How-play-order-is-determined-for-music/m-p/75185/highlight/true#M16192
http://forums.sandisk.com/t5/Clip-Clip/Audiobooks-wont-download-in-order/m-p/108623/highlight/true#M15131
http://forums.sandisk.com/t5/Clip-Clip/ID3-tag-help-to-fix-play-order/m-p/85845/highlight/true#M10891

But the only solutions offered here are
1: Create a Playlist
  I suppose this might work, but it sounds like just as much (or more) trouble than just moving the tracks over one at a time.

2: Rename all files to have tracknumber on end of name
  Ok, THAT works.  But that is just… highly annoying, and again, probably more work than just copying the tracks one at a time.

I LOVE my clip+.  But we did get them primarily for listening to audio books and this seems a very, VERY strange (and annoying) bug.  Any chance it’s going to be fixed soon so that audiobooks will actually order by the filename or tag?

Thanks.

Since you are a linux user I don’t think you’ll be too shy to use the method I used to use with another nonSansa MP3 player I used that also played files in the order they were copied.  I used a command prompt procedure to make a batch file and run it to do the copying in order.

On the windows machine, I’d open a command window and CD to the directory where the MP3 files lived.  Then I would do the command:

     DIR *.mp3 /B > TEMP.BAT

Which would create a text file with the bare MP3 file names, one per line.

Then open TEMP.BAT in a text editor, and put a "COPY " at the front of each line, and append the drive letter where the MP3 player is mounted to the end of each line.  so you end up with a file with lines like

    COPY spaceprison_01_godwin_64kb.mp3     F:
    COPY spaceprison_02_godwin_64kb.mp3     F:
    COPY spaceprison_03_godwin_64kb.mp3     F:
    COPY spaceprison_04_godwin_64kb.mp3     F:

You can also use the text editor to fix problems like the fact that CHAPTER11.mp3 comes in alphabetical order before CHAPTER2.mp3.

Sometime it is useful to reformat the MP3 player to get a virgin FAT filesystem directory, or at leadt MKDIR a new directory and CD to it on the drive letter of the MP3.  That way there is not residual junk in the filesystem directory.

The Clip+ uses tags for sorting. To have the files of the book kept together as a unit, give them all the same album tag. To keep them in the correct order, use the track number tags. A good idea for track numbers is to start with 101, so you won’t need to add leading zeros.

@jk98 wrote:

The Clip+ uses tags for sorting.

Not according to my test.  I took a book and ensured that they were all tagged with the same album, and had the track tags in sequence.  They still played in the order they were copied, NOT in track order.  Try it.

@jdluckey wrote:

Since you are a linux user I don’t think you’ll be too shy to use the method I used to use with another nonSansa MP3 player

 

That would certainly work, or I can even write the wife a simple program to copy the files in alphabetical (or even tag) order.

 

But it just doesn’t seem that this should be necessary.   Audio books should automatically play in either alphabetical or tag order.

"Re: Audio Book Order on the clip+[New] Options Mark as New Bookmark Subscribe Subscribe to RSS Feed Highlight Print Email to a Friend Report Inappropriate Content 11-25-2010 10:46 PM JK98 wrote: The Clip+ uses tags for sorting. “Not according to my test.”

Then your testing is faulty. On my Clip+ files always play in the correct order based on the track numbers.If tags are missing or in an incorrect format, then the player tries to sort on other criteria. Did you use leading zeros for the track number tag, ie. 001, 002, 003  or start numbering them at 101?

The Clip+ need tags in the format ID3v2.3 ISO-8859-1

  >Then your testing is faulty. On my Clip+ files always play in the correct order based on the track numbers.

  >If tags are missing or in an incorrect format, then the player tries to sort on other criteria.

I repent in dust cloth and ashes.  I don’t know what I messed up in my previous tests, probably the track tag somehow.  But when I repeated the test it sorts by track tag.     I’ll go repeat the test on the windows machine because I swear I tested it with the correct track tags MULTIPLE times.

Thank you for the correction.

@donaldh wrote:

I repent in dust cloth and ashes.  I don’t know what I messed up in my previous tests, probably the track tag somehow.  But when I repeated the test it sorts by track tag.  link  I’ll go repeat the test on the windows machine because I swear I tested it with the correct track tags MULTIPLE times.

 

Thank you for the correction.

Hello! What was the result of the test performed on the windows machine?