Audiobooks wont download in order.

I have downloaded the 4 twilight audiobooks and I can’t get them put on the Clip in order. After I drop them on the player I go back to make sure all the files are in numerical order and they are but after I disconnect the player and look in the audiobook file. The files jumps from file 1 to 22 to 12 to 140 and so on not in any kind of order. I have updated the firmware, I have made sure before dropping and dragging to the Clip that they are in order. I am so frustrated. Has anyone had this problem or a fix to it.

Thank you in advance.


it’s probably because of the “tag” system this device use’s. 

Basically, when u copy files to the sansa, it’s gonna arrange the files according to how their tagged, not according to how their named.  There’s some tag converter program out there somewhere but I haven’t investigated that yet so I dunno.

I also copied a few audio book files to my sansa last night and same thing occurred with me.

The device put the files where it wants to, as opposed to where I would like them or how I would like them arranged.

Not cool! 

Read this posting to maybe understand what I’m saying:


I figured it out.  You have to use Windows Media Player and make a “playlist”.

Add the audio book files into the playlist, arrange them however you want, then save the playlist.

Maybe name the playlist “audio books”.

Then sync the playlist with your sansa, just like you would any other music playlist.

I just tested by creating a playlist with a few audio book files and arranged them how I wanted.

I saved it and sync’ed it up with my device.

Under Music\playlists, I have a playlist called Audio Books and there are the 3 files I put in there.

Check it out :smiley: 

To make a playlist:

1st!  update Windows Media Player to version 11.   I’ve been working on a work computer, had version 9 installed.

Then watch this video

After watching the video, I was able to do what the person was saying but still nothing came up.

After reading more “playlist” post’s, I caught onto people talking about MTP mode vs. MSC mode.

I’ve been tinkering around with these modes all along but now for some reason, my computer is indeed showing the device in 2 different ways when connected to the computer, when before only MTP mode showed the device (via windows explorer)

If the sansa device shows up as a drive letter (via windows explorer) like…Sansa Clip (E), it won’t work.

Disconnect it and set the setting to MTP, now re-connect the device.

Now when I look at it via windows Explorer, I see a cute little device and it says: Sansa Clip 4GB, as opposed to an actualy drive letter. (and the file structure looks completly different then when it’s connected via MSC mode)

Now do what the video says and it should work.

All you need to do is tag the files, It will sort them by track number. Each book will need to have a different name so you don’t have two track 1’s.

So at a minimum, you need album, artist, title and track. Genre must be audiobook.

The problem is that even with proper tags the files still may not be sorted correctly.

Everyone should contact Tech Support and ask SanDisk to fix this.