My Sandisk Sansa clip is doing something annoying

1- it doesn’t play the audiobooks in order

2- it’s making folders when I most certainly didn’t


Really? Over 20 views and not one response?

Hello SkullRanger,

Maybe please provide a bit more information so Sansa Forum readers can make some helpful suggestions?

  1. To play audiobooks in order, maybe try using 2-digit prefixes in your ID3 tags for Album Title and Track Title. Please provide an example of the data you are using for each field in your ID3 tag. (Track Title, Album Title, Artist, Track #, etc).

     Are you using ID3 v2.3 tag format?

  1. What method are you using to copy your audiobook files to the Sansa Clip?

     What is the source of your audiobooks (Overdrive, mp3s from CDs, Audible, etc)?

I imagine there are a wide range of experienced users who can assist you based on the specific information you provide in your follow-up messages.

Best Wishes

@skullranger wrote:

Really? Over 20 views and not one response?

Perhaps because others, like I, have not had your issues . . . .

Please see the suggestion in the previous post, as to the audiobooks issue.  Also, you might try manually reapplying the latest firmware, as to the folders situation (see the firmware sticky thread at the top of this forum)–perhaps a glitch developed over time?  Or, if that doesn’t help, perhaps reformat the player under its System settings (be sure to save any files first, as this will erase your user content)–that sometimes can fix unknown issues.

And back to the audiobooks issue, and amplifying what was written above, are your audiobook file ID3 tags in a correct form and order so that the player will play them back in the correct order?