Sansa Clip 8 gb wrong track order

Hello, I am new to this forum, unfortunately i could not find a solution for my problem using the search option.

I tag my mp3s (mainly audio books) with MP3Tag v2.43. So far, everything worked fine, i gave all the tracks of one audio boock (many CDs) the same album and interprete name, but different titles (usually i set tracknumber=title). But now I have encountered a problem with one audiobook consisting of 153 tracks. No matter how I name the tracks/titles (they show the correct order in mp3tag), they appear in the wrong order on my sansa clip, for example in this order:











and so on…

Does anyone know about this problem and how to solve it? I even deleted all tags and created completely new ones, the problem still occured.

The way you’re numbering them may be confusing the player. I don’t think it supports A/B numbering. Instead of numbering them “001/X”, “002/X”, “003/X”, etc., try just numbering them  “001”, “002”, “003”, etc.

Also, make sure MP3Tag is set to write your tags in ID3v2.3 ISO 8859-1 format. Other ID3 formats aren’t well supported.

Message Edited by gwk1967 on 07-07-2009 01:06 AM

Thanks gwk1967, just naming the tracks from 001 to 153 was the solution!

(Just another question, though it has nothing to do with the topic issue: when creating a playlist with mp3tag directly from the files on the sansa player (and saving the playlist in the folder of these files), I just get to see an “empty” playlist in the sansa clip. Any known solution for that issue? Only found fixes for playlists created with music monkey, but those didnt halp).

That’s strange gwk1967,

I use 01/xx or 001/xxx track numbering on all of my audiobooks and have not had any problem. I typically name them like this for the files associated with a given audiobook;

Same Artist

Same Album

Title is usually “Album - 0x of xx” or “Album - CD 0x - 0x of xx”

Track is always (since I switched to the clip) 01/xx or the 3 digit equivalent.

What firmware version are you using? I am running V02.01.32A. Something else that might be different is most of my books are not labeled with the audiobook genre and they are typically loaded in the music folder (though I don’t think this second part matters).


This bug still exists in Sansa Clip firmware 2.01.35A.  Removing the “/TOTAL” from the tags is a workaround but that tag seems quite standard for a lot of mp3 ripping software.  Can’t the player just ignore the “/TOTAL” part of the track number? Any chance for a fix?  Thanks.

I’m pretty sure the track number tag field overrides any other tag setting. Using mp3tag, have the right hand window list the order you want to play and use the track numbering option (it’s a menu item), to set the track numbering.