Audiobook Track Order

I have an audiobook ripped from CDs with this directory structure:

+[Book Title]

  • [Disc 1]
  • [Track 1]

  • [Track 2]

  • [Disc 2] 
  • [Track 1] 

  • [Track 2] 

The Clip is displaying the tracks in this order:

[Disk 1] [Track 1]

[Disk 2] [Track 1]

[Disk 1] [Track 2]

[Disk 2] [Track 2]

How do I get the tracks to play in the correct order?  I have the latest firmware (01.01.29). The ID tags contain the disc numbers.

Here is how the clip’s heirarchy works. It is dependent on id3 / metatags:

[Album] (Book)

[Title] (Chapters)

Within the Title’s, they will display in order of the track # tag. You’ll have to edit the tags so that they fit this heirarchy. I suggest making all 4 track’s “Album” tag the same name, and changing the “Track#” tag in the order you want it to display.

This thread might help you also.  File Chapters

Message Edited by thoma on 06-18-2008 03:39 PM

The firmware should be corrected so that it reads the Disc number tag. The bright engineers at SanDisk can get this fixed pretty easily. That’s much more reasonable than asking us customers to change all of music and audiobook collections as a workaround.

My Clip with firmware 01.01.18 worked fine with double-albums, once I set the DISCNUMBER correctly with Mp3tag (I think the official name for this field in the spec is TPOS - Track Part Of Set).

The 01.01.18 firmware recognised this, but I notice 01.01.29 seems to ignore it.

I would consider this a regression. Any chance of a fix?

Or does anyone know of any other way of setting the DISCNUMBER or similar, which Imay have missed?

I have not tried 01.01.20 firmware, so I don’t know when this functionality broke.