xp doesn't see clip-can't do firmware update!! help

Just recently my Clip wouldn’t charge up.  so last night I did the MSD (?) and the computer saw it.  I downloaded the firmware updater and thought i downloaded the update.  Still no luck.  So today I tried again, thinking I didn’t really get the update on the Clip, but now my computer won’t see the clip, I can’t access the updater, and it still won’t take a charge.  Help!

Did you try connecting in MSC mode (hold on, plus center button pressed as you connect)?

YES.  I can see it in the control panel but it does not show under ‘safely remove hardware’.  I don’t know what to do next!

tia for the help!

If it’s not writing to the Clip, I’d disconnect and then re-format the Clip, to see if that helps.  You’ll lose the files on your Clip, however …

The only way I can see to do that is to use the main menu but I can’t do that because I can’t even turn the darn thing on!

Any other ideas?

Try hiolding the on switch in the upmost position for 15-20 seconds (or more) to try to reset.

tried that.  when I plug in the player in MSC (?) mode the player looks empty.  when i plug it in just normally i can see all my music.

I wonder if i am missing a step with the firmware download.  I downloaded it using the updater…do I need to do something to get it to the clip?

thanks

The update should do it all automatically. 

Why you don’t see music:  when connected in MSC mode, you only see on your comouter music transferred in MSC mode.  Same as to MTP mode.  A computer quirk.  And why I set my Clip to MSC mode (it’s more universal for computers; and MTP mode really is only needed for DRM music/files).  Hope this helps explain it.

Thanks for the explanation.

in WMP there is an option to format. Do you think that will work?

I’m not that familiar with WMP, but if nothing else is working for you, I might try it …

:wink:

that worked to reformat.  I don’t think the firmware update installed because everytime I tell the updater to look for updates it shows 1.01.29 available.  I believe I saw on another post that someone had to drag a file to the clip for the update to complete.  does that sound right?

(I switched cables too…no change)

Here’s the link to the firmware update thread.  I would skip the Updater and just apply it manually–it will take less than a minute!

http://forums.sandisk.com/sansa/board/message?board.id=clip&thread.id=6720

And good to hear that you’re up and running–

Message Edited by Miikerman on 05-23-2008 12:00 PM

:frowning:

no luck.  i applied the update but no change.  I still cannot power up the unit.  It shows it is charging but it does not charge.  Now I feel something loose inside.  No, I did not drop it or handle it roughly.  I think it just died.  If you have no more suggestions I am going to call tech support when I get home from work.

thanks

This actually worked for me!!  My sansa clip died mid-song and would not turn back on and I tried many, many times.  I tried plugging it into the computer, and my computer would not read the device at all.  I held the on switch for a long time (about a minute and a half) and it reset the sansa clip.  Now it is working properly.  I’m so relieved.  I use the recording device for work and the sound quality is really good.