Neither recommended Firmware 01.01.32 updates work


Yet again, I am having difficulty updating my Clip’s firmware. This time from 01.01.30 to 01.01.32.  I get a failure when using the Sansa Updater 1.200, “The Installation failed. Please try again later”. I also tried the suggestion of taking the firmware update file and directly inserting this into the root directory. However, the Clip will not let me put this file (m300a.bin) into the root directory…only various subdirectories.

I wanted to update the firmware thinking it might be a solution to reversing the extreme slowing down of starting and turning off the clip. Very weird. I tried reformatting and although it did it once after restarting the unit the music was still there. I tried various ways numerous times (directly from the Settings menu on the clip to connecting the clip to my XP PC in USB Auto, MCS, and MTP.) I just “formatted” the clip through the Settings. It completed, I couldn’t find any music, plugged it into my PC, saw that there was no music, disconnected from the PC, restarted the Clip and my music files were back. Go figure. (Incidentally, I get an error message when trying to reformat for the DOS command line or through Windows Explorer.)

I also hacked the registry to remove any mention of the unit’s PID keys and then reinstalled the Updater software but this had no effect either. Additionally, every time I unplug the Clip from the computer it takes well over 2 minutes to get thru “disconnecting” through refreshing the database.

To summarize my issues: (1)  I cannot update the firmware through either of the two suggested methods. (2) I cannot reformat the Clip either from the Clip itself, using a DOS command line format, or through Windows Explorer. (I have XP with SP3.)

Any suggestions?

I have the same problem with a 4gb sansa clip (firmware version 01.01.29). 

Interestingly, if I connect in MSC mode, I can see a folder named ##music#.  If I open this folder, I see more folders that match the folders in the root directory.  the music folder in this folder has all my music, but when I delete/rename them, I get a message saying I can’t, then the desired deletion/renaming appears to happen, but when I disconnect and reconnect, everything is the same as before.  When I turn off the read only property in the properties box, I also get an error followed by the apparent action being successful.  I observe the same behavior with windows XP and Vista64.

Message Edited by rstudent on 03-05-2009 12:04 PM

When you see this format of folder, your filesystem is zorched.  Have a look at the other folders in the root directory; the originals may be intact.

In the past, I simply deleted the duplicates, and all was well.

If this doesn’t do the trick, simply format the device and start anew.

As for the Firmware Updater, fear not!  Simply download your firmware file, either revision 1 or 2, unzip it, and drag -and-drop the bin file into the root directory.  Check the Firmware thread for the latest firmware build.

The step by step directions are very straightforward, in this thread.  Manually installing the firmware is a snap.

The firmware can be installed in either MSC or MTP mode; the difference is that you must double click on “Internal Memory” to open the root directory.

The bin file must be placed in the Explorer box that represents the device root.  DO NOT plop the file into any of the folders, simply place it in the box along side them.

Bob  :smileyvery-happy:

I’m having this problem…highly irritating…

 The problem is Bob that we cannot drag the firmware update into the root folder to begin with…

my Clips stupidly slow, i can’t format it however i try, i’ve tried resetting… it just loads up again with all the stupid music i’ve been trying to get off it…

firmware updater always fails, the device is never properly reckognised. I’m using 1.0.29 4gb sansa clip…

what to do?! 

can you format the device through the settings menu? if not it may be hosed try contacting support

I can format it in WMP11 and through settings on the player but it does nothing…WMP11 says its formatted… player says it isn’t, reinstalling WMP11 = same result

when i load it back up again all the music is still there after format through player and WMP11

I’ve tried putting it in MSC mode and formatting through windows but it fails “format could not complete”

The answer seems to be to find a way to format it somehow…then put that manual firmware update file in it and hope it sorts itself out…

but i shouldn’t have to do that… I’ve never heard of any device being unformattable…

I’m stuck for ideas now though…