i cant get my clip to work on the comp

ok so, when i hook my clip up to the comp, i open up the thing that says internal memory and i get this screen

 

Try to format the player using the internal Format option and plug in the Clip again.

Go Sansa!

i tried that already and it didnt work. ill try it a few more times, but i doubt itll work. It also didnt work when i right clicked the thing that said internal memory and said format. jsut locked up my computer, lol

Your Clip is communicating in MTP mode OK, but the file structure is messed up.  Formatting from the device, and cycling the power on the Clip, should force the device to build a new group of the requisite folders.

If it still misbehaves, install a new copy of the firmware as shown in the firmware thread.  This will start you over on a clean slate.  The firmware is responsible for building these default folders; there may be an issue there.

Bob  :smileyvery-happy:

when i try putting the firmware on it wont access it. but ill try turning it on and off while formating

i open up the file, and i try to put in the firmware thing, but it says it cant access and just skips putting it on there

ok so the formatting and turning it on and off did nothing at all. im lost

ok, new idea. any idea how to like, instantly wipe the memory from this thing without having to connect it or use the format thing?

The format “thing” I am referring to is on the device itself, go to Settings > Format > Yes.  Note that this will erase all data on the device.

After the format operation, the power can be cycled on the device, and the needed folders will automatically be generated by the Sansa.

The easiest way to update the firmware is to first look at Settings > Info and read the top line.  The current firmware is 1.01.29.  If you need to update to this, the most basic way is to follow the firmware thread, either installing the Sansa Updater (allowing the firmware to be installed automatically) or by manually downloading a copy of the firmware.  Print the directions in the firmware thread to use as a guide during the process.

Bob  :smileyvery-happy:

ive tried this plenty of times. it jsut regenerates the same corrupt files. and when i turn it back on, all the songs are back.

Ah, I see.

If the format command isn’t erasing correctly, it’s pointing to exactly where the problem may be: the firmware.

Look up the firmware thread here, and install a new copy of the 1.01.29 firmware.  Print out the directions before proceeding, as your guide.

When you download the file, it will be a compressed library file, found here, in the 1.01.29 thread.

Take your time on this process, so you don’t miss any steps. Note that the file you receive is called clip01.01.29a.zip.  This file is NOT USEABLE until it is uncompressed or “unzipped” using WinZip or any other unzipping utility.  When unpacked, the file is almost 16 MB.  The file will be called m300a.bin and after unzipping it, you drag and drop the file to the root directory of the Sansa.

Take note, here’s how to get to the root directory:

Open “My Computer”.  Double click on your Clip.  The window that opens is important, as it will appear in one of two formats depending upon how your Sansa is recognized.  In EITHER case, place the m300a.bin file NEXT TO, BUT NOT INSIDE any of the folders that appear.  Just drag the file into the My Computer window.

If the FIRST double click on the Sansa displays a logo that says “Internal Memory”, you are in MTP mode , and you must double click on this logo in order to open the root directory.

Allow the file to transfer, then disconnect the Sansa.

IF this has been done correctly, with an unzipped binary file (the firmware), the Clip will say " firmware upgrade in progress", and you’re ready to go.

Select your preferred language (I’ll assume English), and then navigate to Settings > Info.

Does the device report 01.01.29?  Success.

Now let’s play it safe and Go to Settings > Format > Yes.

You’re ready to load your happy Clip.

Bob  :smileyvery-happy: 

ive already tried all of htis stuff. and it never worked. which sucks.lol

as soon as i put the m300a.bin file in, it says the device cannot be detected and the file cannot be put in

Try transferring the file in MSC mode, either by selecting MSC directly, ot by starting with the Clip OFF, select LOCK, then hold the center button down while plugging in.  Keep the button depressed until it is recognized.

Bob  :smileyvery-happy: 

at too. the tech support guy had me do that stuff already. id be mad if it was my comp doing this. but i doubt it

When I downloaded the firmware and unzipped it, the file was only about 6 megs. I downladed it 4 seperate times it it was the same each time.

And when I try to drag it to my clip, it comes up with a CRC error. Is there another location to download this file?

I can’t get my clip to do anything. It won’t format either internally or thru explorer. It shows me as having 1.5 gigs free, but when I try to play music, it shows no songs.

I’ve tried chkdsk and it doesn’t work. It doesn’t matter what mode I connect with.

If you can’t write to it, and you get CRC errors when you try in MSC mode, and the database thinks there is content - but it can’t access it…sure sounds like a corrupted filesystem. I could be wrong, but it sounds like bad flash memory on the Clip. If formatting (on the Clip menus, not via Windows etc) doesn’t work or does not fix this, you’ll need to return it.

Message Edited by Click on 06-24-2008 01:01 PM

neutron bob says the uncompressed file should be almost 16 megs, but it is only about 6 megs when I unzipped it. Which is the correct size after decompression?

The unzipped file, called m300a.bin , is 5243904 bytes (5121 KB or 5.00 MB ) on my computer.