Help my sans clip won't download music

My sansa clip won’t download music, when ever I try it says disk problem. I have had it for like 6months now and not had a problem with it. Also when I turn it on it always starts on the last the last song and you have to delete it or it will say all of the songs are that song and everytime I go to turn it back on the song I deleted is back on there. Whats up with this. My biggest problem right now is that it won’t let me download anything. I was goign to format it but I don’t want to dot hat and find out it still won’t let me download and not ahve any music to listen to. Help me please!!??      

Are you able to reapply the firmware?  See the sticky threads at the top of the forum.

yeah its all updated and stuff is there anything else I can try??

Reapplying the firmware is not just for updating, but for fixing any code that has become corrupted over time.  Did you try reapplying the firmware, as stated above?

it won’t let reapply the firmware me I followed all the directions and then when I try to put it in the clip a message pops up and says

Cannot cop clip01.01.30 cannot find specified file. Make sure you specify the correct path and file name.  

what do I do??

Where do you have the firmware placed on your computer’s disk?

How are you trying to copy it to the Clip?

Try unzipping the ZIP file and there should only be one file - m300a.bin - that is the one you need to copy to the root of the Clip.

The file m300a.bin is about 5.00 MB compared to the ZIP file which is about 3.44 MB.  Make sure you’re copying the correct file to the Clip.

You may want to go back to a previous firmware and then update to the latest firmware if just reapplying the current firmware doesn’t work.

Message Edited by SteveG on 10-28-2008 03:20 PM

I’ve tried various ways

save it it directly to it saving it to the computer and then dragging to the drive , and then I just tried it agian and “unziped”

I am saving it to the “D” drive am I doing it wrong??  

What is the name of the file you’re trying to copy to drive “D”?

How is drive “D” displayed when you view it using “My Computer”?

I just did what Steve G said and I still got the same message… the current version is 01.01.18

Save it to your computer’s hard drive.  Unzip it on the hard drive, then move that single file to the clip.

When you say you got the same message, do you mean you got the message “Cannot copy clip01.01.30 cannot find specified file”?

yeah that message… what do I do to fix it ??

oh and thanks everyone for trying to help me :slight_smile:

Are you sure you’re copying the right file to the Clip?

What’s the name of the file you’re trying to copy?

the 300.a something or other

Where is the “300.a something or other” file stored on your computer right now?

Message Edited by PromisedPlanet on 10-28-2008 04:05 PM

its in the “C” drive.

In what directory/folder?

its in none of the folders just as soon as you click its right there in the “C” drive

It’s either still in the zip file, or it’s in a folder.

If it’s still in the zip file, try first copying it to a folder on your disk before copying it to the Clip.

Are you using Windows Explorer to copy the file to the Clip?

Message Edited by PromisedPlanet on 10-28-2008 04:22 PM