Problems with my Sansa Clip

I have used the 2 GB clip on a Windows 2000 machine for a couple of months without any issues. One day, things started to change: 

 

When turning the device on, it stays in “Refresh Database” for a while and then goes to the main menu, forgetting where it was stopped on the last session. 

 

When turning the device off, it stays a while in the “Goodbye” screen before turning off. 

When connecting to the PC, both MSC or MTP, it shows the folders, although incomplete and when clicking on them the contents are empty. It does not allow to add any file to it. This happens both in the Win2000 machine and also on a XP one.

New folders appeared: ##MUSIC## and ##PORT##. 

In XP, when connecting to the PC in MTP mode, it shows as “Sansa M350”. 

I tried formatting from the clip. It says it was done but the files are still there.I tried formatting from the computer, but after a while it says it was not possible to complete.

I tried updating the firmware with the Updater, but it says to try again later.

 

Any ideas of what I can do to solve this?

 

Thanks!

Are you getting this error while formatting the player in my computer? Try formatting the clip from its menu, look for “FORMAT” option under “Settings”.

Try to manualy drag and drop the firmware:

http://forums.sandisk.com/sansa/board/message?board.id=clip&thread.id=6720&view=by_date_descending&page=7

Go to the first thread for firmware and instructions.  Hope it helps.

Go Sansa!

tapicotacupe: I tried formatting from the clip. It shows complete but the files are still there.

SansaMe: I also tried to manualy drag and drop the firmware, but it does not let me add any file to it.

Message Edited by glozzia on 05-23-2008 08:20 AM

Try contacting sandisk technical support at 1-866-726-3475 they might have a fix or consider a replacement for your device :slight_smile: