Sansa clip isn't cooperating!

Hello, everyone.  I’ve been having an issue with my Sansa Clip 4GB.  I searched through this forum and tried all the advice I found, but nothing has worked.

A few days ago I was charging it on my PC which runs Vista.  I happened to be listening to some songs with Windows Media Player 11.  I almost never use that program, so I didn’t realize it would automatically start to synch up with with the Clip.  I didn’t want it to synch up, so I cancelled it, and it seemed to be charging normally after that.

But when I disconnected it, it seemed to sort of freeze on the database refresh.  So I turned it off and then on again.  When it came back on, it took forever to boot up.  Then I noticed it said it had 0 songs, and I haven’t really been able to do anything with it since.

When I turn it on, it takes forever to get past the refresh database screen, but then it goes to the menu like normal.  There just aren’t any songs.  When I connect it to the PC in MTP mode, the computer doesn’t recognize it.  It does show up as removable storage in MSC mode, so I tried a couple of the things that were suggested on this board in the past, but nothing works.

If I try to run chkdsk, it gives me a message that says “The volume does not contain a recognized file system.  Please make sure all the required file system drives are loaded and the volume is not corrupted.”

So I tried to format it, and I made sure to select the FAT32 file format.  It just says “Windows was unable to complete the format” and then when I cancel, “Windows can’t format F: check to see disk and drive are connected properly and make sure they are not read-only.”

I tried to update the firmware too, but if I try to open the files in Windows Explorer or drag & drop the unzipped firmware file, it tells me that I need to format it.  :frowning:

So I’m kind of at a loss.  Any other ideas? 

Also, I don’t know if it makes a difference, but I’ve had it since May and haven’t had any issues with it at all until now.

Thanks in advance!