Sansa Clip freezes at startup

Hey, there. I have a problem with my Sansa Clip device. Here’s what it goes:

It is difficult to turn the player on, but when it lunches - it stucks at initial screen. After a few minutes, it sturns itself off.

And here is what I tried to do with this:

  1. Software reset (15sec and more, a couple of times);

  2. Pluging it to a PC on MSC mode (it sees a portable drive, or sometimes two of them, which is strange, because I don’t have a MicroSD card slot in it; when I try to access the drive - Windows freezes for a while and then asks for reformating; of course it can’t do it)

  3. Plugging it to a PC on MTP mode (the player freezes at flower screen, Windows says that it did’t recognise it, but after a while it works)

And the best of all: I tried to do upgrade. First, in automatic way, but it says I can only download a user guide. Next, in manual way. I’ve downloaded the files needed to upgrade and plug the Sansa Clip on MTP mode.  But when I tried to put the file on a Internal Memory drive - it says I haven’t got the rights to do it. After that, accessing any folder on the device shows an empty folder. To be able to see the files on the player again, I have to right-click the Internal Memory drive and select Format. It does it very quickly. After that, all files are here (o.O), and I can access them. But I cannot write to the memory! It goes again with the no priviliges thing, again.

I tried deleting music files on the device by myself. It goes pretty well. It disapears, and everything is OK. But after refreshing the player (read it as re-pluging in or reformating Internal Memory drive), the files are still there (with a few new, empty files).

My question is - how I can bring my player to live? 

If you can turn the player on, go to settings, system settings, format which will delete all the music on your player. Set the usb mode on the player to MSC, then connect the player to your pc and add files to it. The flash memory on your player may have been corrupted. Try running CHKDSK on your music files to see if it finds corrupted files. If no corrupted files are found, try adding the files a bit at a time though, keeping traack of what you added each time. Disconnect the player after each set of file additions to see if it works properly. You might find problematic files that CHKDSK didn’t find.

From what I believe, if formatting will not resolve the issue, then 100% this would point to a hardware failure. By the way, prior to getting this, did you by any chance modified something? 

Thanks for your reply. But the thing is, that the player doesn’t turn itself on. It goes to the “flower” screen and that’s all. Of course, if I click the center button, the “flower screen” turns off. But the buttons still are highlightted. I have only access to it by the PC, well, sometimes.

And I didn’t modify anything :frowning:

If you can’t turn on the player to format it using the player’s menu, then connect the player and format it using your pc. Disconnect the player and hopefully after that it will turn on. If it turn on after removing the card in the player(if there was one) and formatting the player, then the problem is probably your files and not the player.

Then you could format the player again, this time using the player’s menu, set the player’s usb mode to msc, then reconnect the player and load files on it. You could try just a few files first. Perhaps your tags are in a format the player chokes on. The Sandisk players need ID3V2.3 ISO 8859-1 tags.

 If the problem is not the tags, then you may have some some corrupt files. If you load the music on the player gradually, say 10%, then disconnect and see if the player is okay, then reconnect and put another 10%, then if you have a problem you could delete the last batch you loaded and then examine them in your pc with CHKDSK for corruption.

Thank you for your reply. 

Little update: I have plugged the player into a Linux OS. It recognised it as MTP device and didn’t want to mount it. But when I pluged it out - - it froze and after a while the menu showed up!

As fast as I could, I got to the Options screen. First I have changed the way it would be recognised to MSC device and then I choose to reformat. It had said “Formatting…”. And the screen gone all black after a while.

Now, the screen don’t work at all. When I get to plug it on, it doean’t lights up, of course. Soft reset doesn’t work for this.

In Windows, I have plug it in and I waited for a while. Nothing apeared on the screen, but Windows have recognised it as a MTP device. Again.

I cannot reformat this. I tried from the player. Results are as above. From OS - only as MTP - I can reformat. Then it says that the job have been done and all the files are still there. I cannot plug it as a MSC.

One more thing to say - I cannot write anything to the device. And when I manually delete some files, after pluging it in(or reformat) they are still here.

Is this an original Clip, a Clip+, or a Clip Zip? How old is the player?

This is original Sansa Clip player. It has about 2 yrs and had broken down about 1yr ago. Since then, I didn’t try to do anything with it. I have just given up.

It seems like it is time to get a new player.