Problems with Sansa Clip

I have a black 2gb Sansa Clip V1.

I can’t seem to format it/remove/add files to the player. I can’t even update the firmware in both MSC and MTP modes.

When I try to copy files in MSC mode, it’ll show cyclic redudancy error and it’ll show that I don’t have permissions to copy files in MTP mode.

If I try to format it via the clip, it’ll format and end by saying formatted. After restarting the player, the files will be back in their original position.

I can’t view any of the files via my computer too.

Anyone has an idea?

What happens when you try viewing your files from your computer? Also, how old is your device? Do you have another USB cable at your disposal to make sure that you’re not using a faulty one? Also, how many USB devices do you have simultaneously connected to your PC? Maybe unplugging a few could make a difference…

Well, I tried using another cable, the thing is out of warranty.

Tried using only connecting 1 cable but I get the same results