Cannot Format shows 0 capacity under properties.

This was a replacement 4gb clip at end of september.  It locked up and acted quirky after it did a firmware upgrade when i first got it, but was able to format it and get it to work.  It started acting up a week ago and now basically wont do anything.  Cannot format.   Shows zero capacity after connecting in msc mode(takes 5 minutes. )  cannot copy files onto it.  It has an extra music folder named #music# when under msc mode.  When under normal mode it eventually is recognized but internal memory shows no files or folders.   the original purchase date was 10/15/08 so they wont replace the pos replacement.  spent way too much time talking to them and trying things.  They are saying they sent me a bad replacement player but cannot give me another since it is now past the year warranty of the original purchase.  i am hoping someone has some idea how to maybe low level format it with zeros or anything else that might work.  If not maybe someone can recommend a reliable brand other than sandisk.

Have you tried connecting in mtp mode? If it will connect in mtp mode, then delete all the files you see, then disconnect it, and try formatting the player using its menu. Did you try formatting the player both ways, using the player’s menu, and using your pc?

 It might be the case that the flash memory in the player is defective.

Thanks for the response.  Yes I tried formatting in both mtp and msc modes.  Cannot finish format in either.  When in mtp mode it shows no folders or files.  When in msc mode shows files and folders that cannot be deleted.  Cannot copy or drag files into player under either mode.  It will format using the player(or it says it does) but it acts exactly the same when trying the above mentioned things again(formatted with player several times now). I just wondered if there was some kind of utility that might format it.  I do like the player, though and am taking a chance on a 8gb clip+ and 16gb card i ordered on newegg.  Maybe the third times a charm.  Wish me luck… 

It shows files on the player in msc mode and also shows zero capacity, or did you mean zero free space? Could these files be write protected? Did you try changing the attributes of these files before trying to delete them?

Imo the Clip+ seems more robust than the Clip, although I have both and haven’t had major problems with either of them.

I guess you are aware of the song limit on the Clip+? It is stated as 8,000 however some people were only able to get up to around 6,500 or so songs recognized by the player if they have long filenames, are heavily nested, have long tags, etc. This is not an issue for most people as they are using 128 kbps or higher bitrate(and their songs average around 4 minutes or longer), but has disappointed those expecting to cram 24 GB of 64 or 96 kbps songs on their 8 GB Clip+ that has a 16 GB card in it.

It was showing 0 capacity and 0 free.  Now it shows what it was before it flaked out.  3.79gb cap and 224mb free. File attributes showed read only.  When trying to change from read only, I get a cyclic redundancy error.  The same error shows when trying to copy files to device in either mode.  Thanks for letting me know about the 8000/6500 song limits, i havent heard about this.  I shouldnt bother me, though, since i use it mainly for audio books/programs that are 30-45min per file on average.