Clip+ 8gb won't start, won't format, no recognized properly

I’ve had issues with it on & off as everyone else has, but the current one seems to be the worst. Problem started yesterday. Was listening to it just fine. Once I turned it off, I couldn’t turn it back on again. Still have about 3/4 battery life.

  • it doesn’t come on, I cannot do the 20sec standard reset.

  • computer doesn’t recognise when connected to.

  • connecting through MSC mode (center button press) just tells me that it needs to be formated. It assigns a drive letter but you cannot do anything with it other than the recommended format. However it cannot format it (both quick & normal). Under the format screen, it shows as 30.6mb instead of 8gb and FAT instead of FAT32 - see screenshot at

  • the only 2 times it randomly came on, once yesterday once today, just gets stuff on the sandisk logo start up screen.

Running Win7. I also tried updating firmware, but it’s useless since the computer cannot format or recognise it.

Please help. I love this player. I don’t even care about saving the contents. I just want it to work again.

How old is it?  I hate to say it, but since you’ve tried all the tricks it sounds like the hardware is failing. If it’s still under warranty (1 year US, 2 year Europe), time to call SanDisk and get it replaced.

Looking at Amazon and eBay, the 4G is about $40 new and $25 refurbished at the moment, and you could put a big card in that…so not horribly expensive to get another one either.

I want to say it’s 5yrs old. It’s just weird. Just died all of a sudden without any issues.

I never call these little buggers out.  Sometimes just coming back to them after a couple day rest has them starting up again . . . .