My Clip is empty, but sync says I only have 926 MB remaining

My 2 GHB clip is completely empty, but when I plug it into Windows Media Player, it says that I ony have 926 MB available space; however the internal memory is 1.8 GB.  When I look at the clip manually, it shows no songs, and when I open it with my computer, it shows no songs/content.  Any ideas?

Reformat?

Did you put files on it in different modes (MSC, MTP)?  I’m not sure if you can see files put on in one mode if you are in the other (but I may be thinking of one of my older mp3 players).

I had the same problem.  I went into settings, changed my USB Mode to have a check mark by MSC, added one song to the sansa clip and all 250+ songs appeared.  Good luck!

@rdow wrote:
Did you put files on it in different modes (MSC, MTP)?  I’m not sure if you can see files put on in one mode if you are in the other (but I may be thinking of one of my older mp3 players).

Rdow is absolutely correct:  songs transferred in MSC mode may only be seen on your computer when connected in MSC mode; and likewise as to MTP mode.

The solution (if you care):  use one mode or the other, consistently (set the Clip’s USB/Settings to either MTP or MSC; if you don’t have that option, upgrade to the most recent firmware).

Wow, thanks so much for your advice.  I’ve been messing with this for a few weeks now trying to figure it out.  I re-formatted it and checked MSC under USB settings and now it’s recognizing the correct amount of available space. 

Thanks!