Can't copy or delete files

I can’t copy any music files to the Clip. I have a 4gb Clip which worked fine for two weeks, but now I can’t delete or copy files. I’ve tried every version of resetting, reformatting, MSC/MTP USB mode, etc. that has been suggested on these forums and in the KnowledgeBase. I’m wondering if anyone has had success solving this problem.

I have Windows XP Service Pack 3. I also have the latest firmware installed on the Clip.

Thanks-

Did you try reloading the firmware? Do you have another pc you could test it on? Do you have a spare USB cable you could try(perhaps from a digital camera or cell phone)? The Clip uses a standard cable.

Thanks, but. . .

I’ve tried manually reloading the firmware, but I can’t copy the bin file to the root directory of the Clip (back to my basic problem: I can’t copy any files, music or otherwise). I’ve tested it on two PCs and used two different USB cables.

can you charge the player via a wall charger? You did say that you formatted the player via the player’s menu? I guess there is nothing else you can do besides having it exchanged.

The Clip is fully charged. And I have formatted the player using its menu. I think I’ll just have to exchange it. I also got a 8gb Fuze for Christmas; hopefully it is more reliable. . .

Hi,

I have a similar problem with my new 8GB Sansa Clip.

Once upon time - after using all the treasurous features fine - I found that startup sequence of the player lasted significantly (up to 4-5 or more times) longer than initially. At the same time - and even crappier, the nice “resume from where you played when I turned off” feature was suddenly lost and the player seemed to restart every OFF/ON cycle from the same state. Crap, I thought.

So I tried to remove some of the music files I stored so far to reduce the whatever work for the nice little gadget. But, it isn’t possible, nor in MSC or each other mode to erase the music from the device again. Also I tried to format the drive, same result: After OFF/ON all is there again. I tried that with the players internal formatting function as well as with MS Windows XP, as well as with liunx based tools gparted, fdisk, parted and ‘rm -rf’. Even "Delete song"from the normal menu seems completely ignored after next OFF/ON cycle.

So what should/can I do else?

In your case, if the resume feature is missing (this is only available in the Podcast or Audiobook folders), be sure that you have the latest version of the firmware.

The early versions did not have the Podcast / Audiobook features.

If it isn’t successfully writing these points to memory, either there is a firmware issue, or the save operation is corrupted during power down, when the device says “goodbye”.  Possible, something is amiss in teh cycle of reading / writing this file.

You can contact Support at 1-866-SANDISK for further assistance with your Clip.

Bob  :smileyvery-happy:

You may have to do what I’m doing: working with customer service to return my Clip.