Cant read/write on 4gb clip

Hi,

i had some  problems with my clip before, it stops loading the menu and showed just the logo at the start. After some waiting (30min+) it started normally - as i tried to fix it, installing the latest firmware, he broke the transfer and the player has no more problems than before. I cant copy anything from or to it (in both USB Modes). I even tried to format the whole player, but he didnt do anything, like i tried to reset all settings back to normal, after a new start all was back to normal. I hope you understand what I mean. Thanks for any advice. PS: This is an image of how windows shows my mp3 player right now…

http://img181.imageshack.us/my.php?image=sansayi4.jpg

Unplug your player,  and go to Settings>Format> select yes

This will do a device format

I did it, and it looked like he deleted everything, but as soon as i started him again every song was back again - and the problem is still there.

Btw, he scans every start for a new database. 

Message Edited by Findy on 12-16-2008 04:19 PM

Is there any chance i can fix the player or is he just broken? Any possibilty to start an firmwareupdate without copying the file on the clip?

The player appears broken to me.  id return it ,  or call tech support for an RMA.