I Can't Transfer Files - 2nd Player!

*sorry for a second post. my first post was kinda dead and unresolved…
*perhaps an admin or SanDisk rep could help me since no one responded to my email.

Here is my problem. Few days ago I bought a 2gb clip, upgraded the firmware to .20, added some songs, and made some playlists all in MTP mode. Everything worked fine. Then suddenly in  the same day, i plugged it back in and it didn’t let me add somes or any files. Thus, I couldn’t even reload the firmware. I tried everything, reformat both on the player and windows (in windows nothing happened, the progress bar was blank), reseted the settings, tried using WMP and got errors, and tried both MTP and MSC mode. I tried contacting Sandisk but they were no help. No response at all.

I finally got fed up and went to return the clip today. Feeling bad, I decided to give it a second go thinking i got a lemon the first time around. Brought it home, upgraded the firmware, transfer songs, made playlists, listened to them for a bit, and everything was good. Then i plugged it back in to transfer some more songs, and THE SAME THING HAPPENED AGAIN. It wouldn’t let me do anything. I TRIED EVERYTHING.

This time around, i added some screenshots of the messages i got when i tried transfering a file or song.

  • I cannot DELETE OR ADD anything.
  • It there something i can do to reset everything? Formating doesn’t work.
  • Or should I give up and return the player again for good?

redundancy error!
I/O error!
I don’t have permission?

If anyone has any tips or tricks to get it to work again, I would greatly appreciate it. Thanks!

PS: the last transfer i did left some of my songs corrupted and the clip skips them if that means anything. I tried deleting on the player but they reappear right after i reboot or connect to the computer.

Message Edited by Saigonv on 01-31-2008 09:05 PM

  1. Try other USB ports on your PC.

  2. Try it on another PC (first in MSC mode, then in MTP mode).

  3. If all else fails, CALL Sandisk, don’t email.

If an issue occurs on 2 different devices, that leads me to believe that this is a PC issue not a player issue. I did a few searches online based on the error messages you are receiving and found a couple possible solutions.

#1. This could simply be a port issue. Have you tried all of the USB ports on the PC? Or have you tried the device on another PC? If the same issue occurs on more than one PC it is most likely the device and instead of returning to the store again I would call 866-SANDISK for a possible replacement.

#2. CRC errors usually indicate that the data cannot be written correctly. These errors usually occur when trying to read/write data to scratched/dirty CDs, but in the case of an MSC device this could be caused by the data cable being damaged or perhaps the USB port is not operating properly. Again this is a good reason to try another port or another computer.

#3. I found the same fix on a few sites referring to external hard drives that give the I/O error. Give this a try and see if it chagned anything.

  • Right-click the My Computer icon and then click Manage.
  • Click the Device Manager icon.
  • Click the plus (+) sign next to Disk Drives.
  • Double-click the Sansa Clip icon.
  • Click the Policies button and then click Optimize for performance.
    #4. After doing some research on the third MTP permisisons error, I found several articles referring to how to get Zune players (which is a type of MTP device) to be used as portable storage. This might work for you if you are comfortable editing the registry. This is a little bit of a long-shot since it is for the Zune, but this is really all I found in my research on this problem. Be sure to back-up the registry before you make any changes (file>export in regedit). The original instructions are here, but I’ll paste the directions below and edit it appropriately.
  1. Make sure your Clip is not plugged in
  2. Open regedit by going to the start menu and selecting “run”. Then Type regedt32 and hit “OK”
  3. Browse to HKEY_LOCAL_MACHINE\System\ControlSet001\Enum\USB\
  4. Search for “PortableDeviceNameSpace”. This should be contained in the Vid_####&Pid_############_-_########_-_########_-_########\Device Parameters within the above …\USB\ The ##'s listed here will be numbers and letters specific to your Clip. (Checking in device manager, the Vid is 0781 and the Pid is 7432)

Change the following values: (all of these values may not be present. If they are not here, just skip it)

  1. EnableLegacySupport to 1
  2. PortableDeviceNameSpaceExcludeFromShell to 0
  3. ShowInShell to 1
  4. Plug in your Clip and try to load the firmware file.

Like I said earlier, this really sounds like a hardware issue with your PC. If all of the above mentioned stuff doesn’t work. You should definitely try the device on another computer. If it works on the other PC without any hiccups, it’s definitely a PC issue and you should consider contacting your PC manufacturer and/or Microsoft for further help.

Whew! It’s a slow morning at work so I figured I’d try to help you solve your problem. Don’t tell my boss :wink:

PJ wrote:

If it works on the other PC without any hiccups, it’s definitely a PC issue and you should consider contacting your PC manufacturer and/or Microsoft for further help.

And if you get a response from Microsoft, make sure you contact your local news station as they’ll want to feature you in an evening segment on “most incredible individual of all time.”  :wink:

I’m sure there are some wonderfully helpful people working at Microsoft India™. Unfortunately, I’ve yet to deal with any of them in my endeavors. :smileyvery-happy:

Thank you all for your help, especially PJ for the long explanation. Unfortunately, I tried it on another computer and the same thing happened. I tried editting in the registry and the same thing happened when i plugged the clip back in. I think it is in fact my computer that corrupts the player, causing it to malfunction from that point on. I think I am going to return the player for good because of all the trouble. I just don’t understand why this player causes so me many problems while i have a zen stone plus, ipod video, and zen micro, working flawlessly. If SanDisk releases a new firmware or address this problem somehow in the future, i may buy the clip again.

Thanks again for all the help and support.

  • Andrew

Why not call SanDisk customer support first?